1. 程式人生 > >Num 36 : ZOJ 2100 [ 深度優先搜索算法 ] [ 回溯 ]

Num 36 : ZOJ 2100 [ 深度優先搜索算法 ] [ 回溯 ]

ted without lag enter nbsp pri 搜索算法 finish ring



該題是用回溯法來解決的題:


題目:

Seeding

Time Limit: 2 Seconds Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field,which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. ‘S‘ is a square with stones, and ‘.‘ is a square without stones.

Input is terminated with two 0‘s. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO


題目大意:

從左上角開始行進,能不能不走回頭路的把地圖上全部點走一遍;( S代表障礙物 )。


題目分析:

從左上角開始,利用回溯法進行深搜。推斷有沒有一種情況。能不回頭的把一條路走完;


AC代碼:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int x,y,m,n,snum,max=0,flag;
char map[10][10];
void fun(int x,int y)
{
	if(x<1||x>m||y<1||y>n) return;
    if(map[x][y]==‘S‘) return;
    if(flag==1) return;
	map[x][y]=‘S‘;
	snum++;
	if(snum==m*n)
    {
    	flag=1;
    	return;
    }
	fun(x-1,y);
	fun(x+1,y);
	fun(x,y-1);
	fun(x,y+1);
	snum--;
	map[x][y]=‘.‘;
}
int main()
{
	int i,j;
	while(scanf("%d%d",&m,&n),m|n)
	{
		snum=0;
		for(i=1;	i<=m;	i++)
			for(j=1;	j<=n;	j++)
			{
				scanf(" %c",&map[i][j]);
				if(map[i][j]==‘S‘) snum++;
			}
		flag=0;
		fun(1,1);
		if(flag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}



Num 36 : ZOJ 2100 [ 深度優先搜索算法 ] [ 回溯 ]