1. 程式人生 > >hdu (1556 樹狀數組)

hdu (1556 樹狀數組)

blank ... ons ted spa 依次 u+ code include

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?

pid=1556

Color the ball

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9596 Accepted Submission(s): 4939


Problem Description N個氣球排成一排。從左到右依次編號為1,2,3....N.每次給定2個整數a b(a <= b),lele便為騎上他的“小飛鴿"牌電動車從氣球a開始到氣球b依次給每一個氣球塗一次顏色。可是N次以後lele已經忘記了第I個氣球已經塗過幾次顏色了,你能幫他算出每一個氣球被塗過幾次顏色嗎?
Input 每一個測試實例第一行為一個整數N,(N <= 100000).接下來的N行。每行包含2個整數a b(1 <= a <= b <= N)。


當N = 0,輸入結束。


Output 每一個測試實例輸出一行,包含N個整數,第I個數代表第I個氣球總共被塗色的次數。
Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

Sample Output
1 1 1
3 2 1

Author 8600
Source HDU 2006-12 Programming Contest 題意:如題所看到的~ 思路:典型的樹狀數組題型。區間更新,單點查詢,(從大到小更新,從小到大求和就可以~)
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
const int N=1e5+100;
using namespace std;
int c[N],n;

int lowbit(int x)
{
  return x&(-x);
}

void update(int x,int d)
{
  while(x>0)
  {
   c[x]+=d;
   x-=lowbit(x);
  }
}

int getsum(int x)
{
  int ans=0;
  while(x<=n)
  {
   ans+=c[x];
   x+=lowbit(x);
  }
  return ans;
}

int main()
{
    int a,b;
    while(scanf("%d",&n)!=EOF)
    {
      if(n==0)break;
      memset(c,0,sizeof(c));
      for(int i=0;i<n;i++)
      {
        scanf("%d%d",&a,&b);
        update(b,1);
        update(a-1,-1);
      }
      for(int i=1;i<=n;i++)
      {
        if(i==1)printf("%d",getsum(i));
        else printf(" %d",getsum(i));
      }
      printf("\n");
    }
    return 0;
}




hdu (1556 樹狀數組)