1. 程式人生 > >【BZOJ3831】[Poi2014]Little Bird 單調隊列

【BZOJ3831】[Poi2014]Little Bird 單調隊列

microsoft 維護 bird script you values mil hose single

【BZOJ3831】[Poi2014]Little Bird

Description

In the Byteotian Line Forest there are trees in a row. On top of the first one, there is a little bird who would like to fly over to the top of the last tree. Being in fact very little, the bird might lack the strength to fly there without any stop. If the bird is sitting on top of the tree no. , then in a single flight leg it can fly to any of the trees no.i+1,i+2…I+K, and then has to rest afterward. Moreover, flying up is far harder to flying down. A flight leg is tiresome if it ends in a tree at least as high as the one where is started. Otherwise the flight leg is not tiresome. The goal is to select the trees on which the little bird will land so that the overall flight is least tiresome, i.e., it has the minimum number of tiresome legs. We note that birds are social creatures, and our bird has a few bird-friends who would also like to get from the first tree to the last one. The stamina of all the birds varies, so the bird‘s friends may have different values of the parameter . Help all the birds, little and big! 有一排n棵樹,第i棵樹的高度是Di。 MHY要從第一棵樹到第n棵樹去找他的妹子玩。 如果MHY在第i棵樹,那麽他可以跳到第i+1,i+2,...,i+k棵樹。 如果MHY跳到一棵不矮於當前樹的樹,那麽他的勞累值會+1,否則不會。 為了有體力和妹子玩,MHY要最小化勞累值。

Input

There is a single integer N(2<=N<=1 000 000) in the first line of the standard input: the number of trees in the Byteotian Line Forest. The second line of input holds integers D1,D2…Dn(1<=Di<=10^9) separated by single spaces: Di is the height of the i-th tree. The third line of the input holds a single integer Q(1<=Q<=25): the number of birds whose flights need to be planned. The following Q lines describe these birds: in the i-th of these lines, there is an integer Ki(1<=Ki<=N-1) specifying the i-th bird‘s stamina. In other words, the maximum number of trees that the i-th bird can pass before it has to rest is Ki-1.

Output

Your program should print exactly Q lines to the standard output. In the I-th line, it should specify the minimum number of tiresome flight legs of the i-th bird.

Sample Input

9
4 6 3 6 3 7 2 6 5
2
2
5

Sample Output

2
1

HINT

Explanation: The first bird may stop at the trees no. 1, 3, 5, 7, 8, 9. Its tiresome flight legs will be the one from the 3-rd tree to the 5-th one and from the 7-th to the 8-th.

題解

:根據題意,我們很容易得出下面的轉移方程

1.f[i]=min(f[j]+1) ( i-k≤j<i )
2.f[i]=min(f[j]) ( i-k≤j<i &&h[j]>h[i])

發現上面那個東西用單調隊列直接搞定,但下面那個不太好搞。不過發現由於h[j]>h[i]對答案的貢獻至多為1,所以原來如果f[j]<f[j‘],那麽算上h[j]和h[j‘]的影響後j仍然不會比j‘更差,於是直接維護一個f遞增的單調隊列,其中當f相同的時候使h遞減就行了

#include <cstdio>
#include <iostream>
#include <cstring>
const int maxn=1000010;
using namespace std;
int f[maxn],q[maxn],x[maxn],h,t,n,m,k;
void work()
{
	int i,j;
	q[1]=1,h=t=1,f[1]=0;
	for(i=2;i<=n;i++)
	{
		while(h<=t&&i-q[h]>k)	h++;
		f[i]=f[q[h]]+(x[q[h]]<=x[i]);
		while(h<=t&&(f[q[t]]>f[i]||(f[q[t]]==f[i]&&x[q[t]]<=x[i])))	t--;
		q[++t]=i;
	}
	printf("%d\n",f[n]);
}
int main()
{
	scanf("%d",&n);
	int i;
	for(i=1;i<=n;i++)	scanf("%d",&x[i]);
	scanf("%d",&m);
	for(i=1;i<=m;i++)
	{
		scanf("%d",&k);
		work();
	}
	return 0;
}

【BZOJ3831】[Poi2014]Little Bird 單調隊列