1. 程式人生 > >poj3511--A Simple Problem with Integers(線段樹求和)

poj3511--A Simple Problem with Integers(線段樹求和)

poj pac style som can com onos roman miss

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 60441 Accepted: 18421
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b

" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

將一段的值添加c 求一段的和

將線段樹的每一段表示它代表的那一段的和。統計結果時,要記錄一段的全部的父節點的和。對該段會有影響


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 100000
#define LL __int64
#define lmin 1
#define rmax n
#define lson l,(l+r)/2,rt<<1
#define rson (l+r)/2+1,r,rt<<1|1
#define root lmin,rmax,1
#define now l,r,rt
#define int_now LL l,LL r,LL rt
LL cl[maxn<<2] , lazy[maxn<<2];
void push_up(int_now)
{
    cl[rt] = cl[rt<<1] + cl[rt<<1|1] + (r-l+1)*lazy[rt] ;
}
void push_down(int_now)
{

}
void creat(int_now)
{
    cl[rt] = lazy[rt] = 0 ;
    if(l != r)
    {
        creat(lson);
        creat(rson);
        push_up(now);
    }
    else
        scanf("%I64d", &cl[rt]);
}
void update(LL ll,LL rr,LL x,int_now)
{
    if( ll > r || rr < l )
        return ;
    if( ll <= l && r <= rr )
    {
        lazy[rt] += x ;
        cl[rt] += (r-l+1)*x ;
        return ;
    }
    update(ll,rr,x,lson);
    update(ll,rr,x,rson);
    push_up(now);
}
LL query(LL ll,LL rr,int_now,LL add)
{
    if( ll > r || rr < l )
        return 0;
    if( ll <= l && r <= rr )
        return cl[rt] + ( r-l+1 )*add ;
    push_down(now);
    return query(ll,rr,lson,add+lazy[rt]) + query(ll,rr,rson,add+lazy[rt]) ;
}
int main()
{
    LL i , j , x , n , m ;
    char str[10] ;
    while(scanf("%I64d %I64d", &n, &m) !=EOF)
    {
        creat(root);
        while(m--)
        {
            scanf("%s", str);
            if(str[0] == 'C')
            {
                scanf("%I64d %I64d %I64d", &i, &j, &x);
                update(i,j,x,root);
            }
            else
            {
                scanf("%I64d %I64d", &i, &j);
                printf("%I64d\n", query(i,j,root,0));
            }
        }
    }
    return 0;
}


poj3511--A Simple Problem with Integers(線段樹求和)