1. 程式人生 > >POJ 題目3450 Corporate Identity(KMP 暴力)

POJ 題目3450 Corporate Identity(KMP 暴力)

eof rac mon search ica content log pst abc

Corporate Identity
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 5493 Accepted: 2015

Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST

Source

CTU Open 2007

#include<stdio.h>
#include<string.h>
char str[4040][220];
int next[4040];
void getnext(char *s)
{
	int len=strlen(s);
	int j=0,k=-1;
	next[0]=-1;
	while(j<=len)
	{
		if(k==-1||s[k]==s[j])
		{
			k++;
			j++;
			next[j]=k;
		}
		else
			k=next[k];
	}
}
int kmp(char *a,char *b)
{
	int i,j;
	i=j=0;
	int n=strlen(a);
	int m=strlen(b);
	getnext(b);
	while(i<n)
	{
		if(j==-1||a[i]==b[j])
		{
			i++;
			j++;
		}
		else
			j=next[j];
		if(j==m)
			return 1;
	}
	return 0;
}
int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		int i,j,k;
		for(i=0;i<n;i++)
		{
			scanf("%s",str[i]);
		}
		int len=strlen(str[0]);
		char temp[220],ans[220]="";
		for(i=0;i<len;i++)
		{
			int cnt=0;
			for(j=i;j<len;j++)
			{
				temp[cnt++]=str[0][j];
				temp[cnt]=‘\0‘;
			//	getnext(temp);
				int flag=0;
				for(k=1;k<n;k++)
				{
					if(!kmp(str[k],temp))
					{
						flag=1;
						break;
					}
				}
				if(!flag)
				{
					if(strlen(temp)>strlen(ans)||(strlen(temp)==strlen(ans)&&strcmp(temp,ans)<0))
						memcpy(ans,temp,sizeof(temp));
				}
			}
		}
		if(strlen(ans)==0)
			printf("IDENTITY LOST\n");
		else
			printf("%s\n",ans);
	}
}


POJ 題目3450 Corporate Identity(KMP 暴力)