1. 程式人生 > >hdu 1679 The Unique MST (克魯斯卡爾)

hdu 1679 The Unique MST (克魯斯卡爾)

plm () pst cati 卡爾 nts 相等 cat get

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24152 Accepted: 8587

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V‘, E‘), with the following properties:
1. V‘ = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E‘) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E‘.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!‘.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

題目鏈接:http://poj.org/problem?

id=1679

題目大意:n個點m條路。給出每條路以及邊權。推斷最小生成樹是否是唯一的。

解題思路:克魯斯卡爾,推斷是否存在等效邊。這題數據太弱了。我推斷等效邊的方法不太對,竟然過了= =

代碼例如以下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int fa[102];
struct EG
{
	int u,v,w;
}eg[5005];
void get_fa()
{
	for(int i=0;i<105;i++)
		fa[i]=i;
}
int find (int x)
{
	return x==fa[x]?x:fa[x]=find(fa[x]);
}
void Union(int a,int b)
{
	int a1=find(a);
	int b1=find(b);
	if(a1!=b1)
		fa[a1]=b1;
}
int cmp(EG a,EG b)
{
	return a.w<b.w;
}
int main(void)
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m,ans=0,p=0,cnt=0;
		get_fa();
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&eg[i].u,&eg[i].v,&eg[i].w);
		}
		sort(eg,eg+m,cmp);
		for(int i=0;i<m;i++)
		{
			if(find(eg[i].u)!=find(eg[i].v))//假設當前邊須要增加且下一條邊也須要增加且它們權值相等即為等效邊
			{
				if(i+1<m&&find(eg[i+1].u)!=find(eg[i+1].v)&&eg[i].w==eg[i+1].w)
				{
					p=1;
					break;
				}
				Union(eg[i].u,eg[i].v);
				ans+=eg[i].w;
				cnt++;
			}
			if(cnt>=n)
				break;
		}
		if(!p)
			printf("%d\n",ans );
		else
			printf("Not Unique!\n");
	}
}


hdu 1679 The Unique MST (克魯斯卡爾)