1. 程式人生 > >POJ 1260-Pearls(DP)

POJ 1260-Pearls(DP)

ctype set lowest cas str pri font mount scan

Pearls
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7465 Accepted: 3695

Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000).
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344
水DP
題意: n件物品,給出數量和價格。(註意數量和價格都是升序給出的這個是能DP的關鍵)。要買掉所以商品 對於每類物品。所須要的價格是(a[i]+10)*p[i] ,即要多買10件,也能夠把價格低的物品合並到高價格的物品那 即 (a[j]+a[i]+10)*p[j];代表把價格為i的物品合並到j上。設dp[i]為買完第i類物品的最優解
dp[i]=min(dp[i],dp[j]+(a[j+1]+a[j+2]+a[i]+10)*p[i]);
即對於第i類物品來說。它最多合並前面的i-1種物品,並且由於物品數目和價格都是升序的。所以能夠證明僅僅要 第j類物品能合並,那麽再往後就都能合並,由於第j類物品合並省出的錢能夠表示為 a[j]*p[i]-(a[j]+10)*p[j] ;假設上式小於0,說明能夠合並j,而當j增大,數目和價格都增大。所以僅僅會比j的時候更加省錢。即更能替換。
綜上。有兩種辦法:
1.從前往後推,狀態轉移方程上面以給出。
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <deque>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 116
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
int n,a[110],p[110],dp[110],s[110];
int main()
{
	int T;
	scanf("%d",&T);
    while(T--)
	{
		scanf("%d",&n);
		s[0]=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&a[i],&p[i]);
			s[i]=s[i-1]+a[i];
		}
		dp[0]=0;
		for(int i=1;i<=n;i++)
		{
			dp[i]=dp[i-1]+(a[i]+10)*p[i];
			for(int j=0;j<i;j++)
				dp[i]=min(dp[i],dp[j]+(s[i]-s[j]+10)*p[i]);
		}
		printf("%d\n",dp[n]);
	}
	return 0;
}
2.從後往前推。由於對於最後一種狀態n,要從前面的n-1種狀態中倒著連續合並。
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <deque>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 116
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
int n,a[110],p[110],dp[110],s[110];
int dfs(int x)
{
	if(x<1)return 0;
	if(dp[x]>=0)return dp[x];
	if(x==1)return dp[x]=(a[x]+10)*p[x];
	dp[x]=(a[x]+10)*p[x]+dfs(x-1);
	for(int i=x-1;i>=1;i--)
		dp[x]=min(dp[x],dfs(i-1)+(s[x]-s[i-1]+10)*p[x]);
	return dp[x];
}
int main()
{
	int T;
	scanf("%d",&T);
	while (T--)
	{
		s[0]=0;
		memset(dp,-1,sizeof(dp));
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&a[i],&p[i]);
			s[i]=s[i-1]+a[i];
		}
		printf("%d\n",dfs(n));
	}
	return 0;
}

   

POJ 1260-Pearls(DP)