1. 程式人生 > >HDU1018 Big Number n!的位數

HDU1018 Big Number n!的位數

math sam which n-2 printf ever ber some mil

Big Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31053 Accepted Submission(s): 14398


Problem Description In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107
on each line.

Output The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19  		一個整數n的位數:log10(n)+1此題答案為:log10(n!)+1.log(n!)=log(n)+log(n-1)+log(n-2).....+log(1)
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;

int main()
{
    int i,j,n,T,res;
    double t;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        t=0;
        for(i=1;i<=n;i++)
            t+=log10(i);
        res=(int)t+1;
        printf("%d\n",res);
    }
    return 0;
}


HDU1018 Big Number n!的位數