1. 程式人生 > >[ACM] HDU 5086 Revenge of Segment Tree(全部連續區間的和)

[ACM] HDU 5086 Revenge of Segment Tree(全部連續區間的和)

chm over lar and wikipedia iss ecif tree mtk

Revenge of Segment Tree



Problem Description In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the structure is built. A similar data structure is the interval tree.
A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.
---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.
Input The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 10
2. 1 <= N <= 447 000
3. 0 <= Ai <= 1 000 000 000
Output For each test case, output the answer mod 1 000 000 007.
Sample Input
2
1
2
3
1 2 3

Sample Output
2
20
HintFor the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.
Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.
And one more little helpful hint, be careful about the overflow of int. 

Source BestCoder Round #16


解題思路:

給定n個數的數列,求全部連續區間的和。。最簡單的一道題,智商捉急啊,沒想到。。

對於當前第i個數(i>=1),我們僅僅要知道有多少個區間包含a[i]就能夠了,答案是 i*(n-i+1), i代表第i個數前面有多少個數,包含它自己。(n-i+1)代表第i個數後面有多少個數,包含它自己,然後相乘,代表前面的標號和後邊的標號兩兩配對。

如圖:

技術分享

上圖數列取得不恰當,標號和數正好相等。比方數列1,4,2。4。5。圖也是和上圖一樣的。

關鍵的是標號,而不是詳細的數。

代碼:

#include <iostream>
#include <stdio.h>
using namespace std;
#define ll long long
const ll mod=1000000007;
ll n;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        ll x;
        ll ans=0;
        for(ll i=1;i<=n;i++)
        {
            scanf("%I64d",&x);
            ans=(ans+i*(n-i+1)%mod*x%mod)%mod;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

註意輸出 I64

[ACM] HDU 5086 Revenge of Segment Tree(全部連續區間的和)