1. 程式人生 > >HDU4763-Theme Section(KMP+二分)

HDU4763-Theme Section(KMP+二分)

mat 20px 題意 ngs algo get names col con

Theme Section

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1098 Accepted Submission(s): 570


Problem Description It‘s time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a ‘theme section‘. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ‘EAEBE‘, where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters ‘a‘ - ‘z‘.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?



Input The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
Output There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

Sample Input
5
xy
abc
aaa
aaaaba
aaxoaaaaa

Sample Output
0
0
1
1
2
題意:輸出最長的前綴, 前綴要滿足在原串中至少匹配3次
思路: 二分前綴的結尾點。右邊為3分之中的一個原串,用KMP 統計出現次數。就可以
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int  maxn = 1000000+10;
int next[maxn],n;
char str[maxn];

void getNext(){
    next[0] = next[1] = 0;
    for(int i = 1,j; i < n; i++){
        j = next[i];
        while(j && str[i] != str[j]) j = next[j];
        if(str[i] == str[j]) next[i+1] = j+1;
        else next[i+1] = 0;
    }
}

bool find(int ed){
    int cnt = 0;
    for(int i = 0,j = 0; i < n; i++){
        while(j && str[i] != str[j]) j = next[j];
        if(str[i]==str[j]) j++;
        if(j==ed){
            ++cnt;
            j = 0;
            if(cnt>=3) return true;
        }
    }
    return false;
}

int binary_search(){
    int L = 1,R = n/3+1,mid;
    while(L <= R){
        mid = (L+R)>>1;
        if(find(mid)){
            L = mid+1;
        }else{
            R = mid-1;
        }
    }
    if(find(L)) return L;
    else if(find(R)) return R;
    else return  L-1;

}

int main(){

    int ncase;
    cin >>  ncase;
    while(ncase--){
        scanf("%s",str);
        n = strlen(str);
        getNext();
        printf("%d\n",binary_search());
    }
    return 0;
}


HDU4763-Theme Section(KMP+二分)