解決方法 中文翻譯 cache pro 項目 新的 pen gin resolve

昨天使用5.3.版本的laravel框架開發公司新項目,

發現將cache和session設置為了redis,執行了一下首頁訪問。

如圖:技術分享

laravel 版本號:

技術分享

簡單配置一下控制器路由:

Route::get(‘home‘, [email protected]);
Route::get(‘/‘, [email protected]);


訪問出現錯誤!!!
說找不到一個類:找不到Class ‘Predis\Client‘ not
found


查了查源碼,發現少了一個vendor/目錄下少了一個包predis,
執行:composer require predis/predis 安裝這個包就好
註:版本<5.3可以成功解決問題。>5.3的,失敗!

控制臺錯誤信息如下:

Updating dependencies (including require-dev)
Failed to decode response: zlib_decode(): data error
Retrying with degraded mode, check https://getcomposer.org/doc/articles/troubleshooting.md#degraded-mode for more info
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package laravel/passport (locked at v1.0.0, required as 1.0.8) is satisfiable by laravel/passport[v1.0.0] but these conf
lict with your requirements or minimum-stability.
Problem 2
- Installation request for laravel/passport 1.0.8 -> satisfiable by laravel/passport[v1.0.8].
- laravel/passport v1.0.8 requires symfony/psr-http-message-bridge ^0.3.0 -> satisfiable by symfony/psr-http-message-bridge[v0.3] but th
ese conflict with your requirements or minimum-stability.


Installation failed, reverting ./composer.json to its original content.

中文翻譯:【更新的依賴(包括需要開發)
無法解碼的回應:zlib_decode():數據錯誤
重試與降級模式,檢查HTTPS:/ / getcomposer。org /文件/物品/故障排除。MD #降級模式的更多信息
你的要求不可能解決,對包的安裝設置。
問題1
-請求的包laravel /護照(鎖定在V1.0.0,需通過laravel 1.0.8)/護照[ V1.0.0 ]但這些配置可滿足
沖突與您的要求或最小穩定。
問題2
安裝要求laravel /護照1.0.8 ->滿足由laravel /護照[┊]。
- laravel /護照/ PSR symfony┊需要HTTP消息橋^ 0.3.0┊->滿足由symfony / PSR HTTP消息橋[ V0.3 ]但
這些沖突與您的要求或最小穩定。
安裝失敗,回復到原來的內容。/ composer.json。】

解決方法:[]中括號中為可選項

修改 項目Conposer.json文件 + 刪除Conposer.lock +[執行composer clearcace] + [執行composer update] +執行:composer require predis/predis

技術分享

 








laravel redis 使用遇到問題