1. 程式人生 > >POJ 1836 Alignment(DP max(最長上升子序列 + 最長下降子序列))

POJ 1836 Alignment(DP max(最長上升子序列 + 最長下降子序列))

mission weight ring limit problem stream [0 sin ++

Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14486 Accepted: 4695

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line‘s extremity (left or right). A soldier see an extremity if there isn‘t any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
? 2 <= n <= 1000
? the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source

Romania OI 2002

題意:有n個士兵,每個士兵都有一個身高,如今他們依照左右順序進行站隊,求刪去最小的士兵數。是的每個士兵都能通過左邊或者右邊的無窮遠處。
思路:枚舉每個士兵,算出以他為最長上升子序列的終點,以他的後一個士兵作為最長下降子序列的起點,求出這種最大值。


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

#define inf 9999
#define INF -9999

using namespace std;

int n;
double a[1010];
double dp1[1010],dp2[1010];

int res1(int len,double num)
{
    int l = 0;
    int r = len;
    while(l!=r)
    {
        int mid = (l + r) >> 1;
        if(dp1[mid] == num)
        {
            return mid;
        }
        else if(dp1[mid]<num)
        {
            l = mid + 1;
        }
        else
        {
            r = mid;
        }
    }
    return l;
}

int res2(int len,double num)
{
    int l = 0;
    int r = len;
    while(l!=r)
    {
        int mid = (l+r)>>1;
        if(dp2[mid] == num)
        {
            return mid;
        }
        else if(dp2[mid]>num)
        {
            l = mid + 1;
        }
        else
        {
            r = mid;
        }
    }
    return l;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%lf",&a[i]);
        }
        int len1 = 1,len2 = 1;
        dp1[0] = -99;
        dp2[0] = 99;
        int maxx = -100;
        for(int i=1; i<n; i++)
        {
            int ans = 0;
            len1 = 1;
            dp1[0] = -99;
            for(int j=1; j<=i; j++)
            {
                dp1[i] = inf;
                int k1 = res1(len1,a[j]);
                if(k1 == len1)
                {
                    len1++;
                }
                dp1[k1] = a[j];
            }
            ans = len1 - 1;
            len2 = 1;
            dp2[0] = 99;
            for(int j=i+1; j<=n; j++)
            {
                int t = (j - i);
                dp2[t] = INF;
                int k2 = res2(len2,a[j]);
                if(k2 == len2)
                {
                    len2++;
                }
                dp2[k2] = a[j];
            }
            ans += len2 - 1;
            maxx = max(maxx,ans);
        }
        printf("%d\n",n - maxx);
    }
    return 0;
}


POJ 1836 Alignment(DP max(最長上升子序列 + 最長下降子序列))