1. 程式人生 > >POJ 1466 Girls and Boys (匈牙利算法 最大獨立集)

POJ 1466 Girls and Boys (匈牙利算法 最大獨立集)

involve form cst line problem rep post print should


Girls and Boys
Time Limit: 5000MS Memory Limit: 10000K
Total Submissions: 10912 Accepted: 4887

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

Source

Southeastern Europe 2000

題目鏈接:http://poj.org/problem?id=1466

題目大意:一些男的和一些女的有的之間有關系,同性之間無關系,求一個最大的集合。使得裏面隨意兩人沒有關系

題目分析:裸的最大獨立集問題,建立二分圖,然後依據最大獨立集=點數-最大匹配,求解就可以,註意因為二分圖是雙向建立的。求出的最大匹配要除2

#include <cstdio>
#include <cstring>
int const MAX = 505;
bool g[MAX][MAX];
bool vis[MAX];
int cx[MAX], cy[MAX];
int n;

int DFS(int x)
{
    for(int y = 0; y < n; y++)
    {
        if(!vis[y] && g[x][y])
        {
            vis[y] = true;
            if(cy[y] == -1 || DFS(cy[y]))
            {
                cy[y] = x;
                cx[x] = y;
                return 1;
            }
        }
    }
    return 0;
}

int MaxMatch()
{
    memset(cx, -1, sizeof(cx));
    memset(cy, -1, sizeof(cy));
    int res = 0;
    for(int i = 0; i < n; i++)
    {
        if(cx[i] == -1)
        {
            memset(vis, false, sizeof(vis));
            res += DFS(i);
        }
    }
    return res;
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        memset(g, false, sizeof(g));
        for(int i = 0; i < n; i++)
        {
            int x;
            scanf("%d", &x);
            int num;
            scanf(": (%d)", &num);
            for(int j = 0; j < num; j++)
            {
                int y;
                scanf("%d", &y);
                g[x][y] = true;
            }
        }
        int ans = MaxMatch();
        printf("%d\n", n - ans / 2);
    }
}



POJ 1466 Girls and Boys (匈牙利算法 最大獨立集)