1. 程式人生 > >poj 1087 A Plug for UNIX(字符串編號建圖)

poj 1087 A Plug for UNIX(字符串編號建圖)

ret pty ted opera dry clu accept each 其它

A Plug for UNIX
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14862 Accepted: 5026

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn‘t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

Source

East Central North America 1999

題目大意:這題題目意思實在太難懂,只是題目意思搞清楚之後還是比較好做的

在這個題目裏有兩種物品,一個是插座,一個是電器插座僅僅有一個插孔和一
個插頭,電器僅僅有一個插頭首先有n種插座,n種插座用字符串表示,這n種插
座能夠理解為是插在電源上的插座然後有m個電器。如今電器要充電,電器用
字符串表示,每一個電器都有自己能夠插的插座(這個插座能夠不是那n個插在電
源上的插座。能夠是其它的插座)如今有k個信息s1 s2代表s1插座能夠插到s2
插座上去,這裏類似於將插頭轉換了一下這些s1與s2也能夠不是那n個插在電
源上的插座給出這些個信息問你還有多少個電器沒有插座能夠用
建圖:
建一個源點,指向全部電器。容量為1
全部電器指向他們能夠插的那個插頭上。容量為1
假設一個插頭能夠插到還有一個插頭,那麽將s1指向s2。容量為無限大
將全部插在電源上的插頭指向匯點,容量為1


然後從源點到匯點求最大流就可以
只是建圖會比較復雜,由於涉及到字符串的處理。所以用map容器比較好做點

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue> 
#include<map> 
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define M 1000
struct node{
	int v,next,w;
}mp[M*M];
int head[M],dis[M],cnt,st,et;
void add(int u,int v,int w){
	mp[cnt].v=v;
	mp[cnt].w=w;
	mp[cnt].next=head[u];
	head[u]=cnt++;
	mp[cnt].v=u;
	mp[cnt].w=0;//有向圖 
	mp[cnt].next=head[v];
	head[v]=cnt++;
}
int bfs(){
	memset(dis,-1,sizeof(dis));
	queue<int> q;
	while(!q.empty()) q.pop();
	dis[st]=0;
	q.push(st);
	while(!q.empty()){
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=mp[i].next){
			int v=mp[i].v;
			if(mp[i].w && dis[v]==-1){
				dis[v]=dis[u]+1;
				q.push(v);
				if(v==et)	return 1;
			}
		}
	}
	return 0;
}
int dinic(int u,int low){
	if(u==et || low==0) return low;
	int ans=low,i,a;
	for(i=head[u];i!=-1;i=mp[i].next){
		int v=mp[i].v;
		if(dis[v]==dis[u]+1 && mp[i].w && (a=dinic(v,min(ans,mp[i].w)))){
			mp[i].w-=a;
			mp[i^1].w+=a;//開始的時候寫成mp[i].v,,找了半天錯。擦擦擦擦擦 
			ans-=a;
			if(ans==0) return low;
		}
	}
	return low-ans;
}
int main(){
	int t,i,j,k,n,tot;
	char str[30],ch[30];
	scanf("%d",&n);
	map<string,int> m;
	cnt=0; tot=1;//給電器編號 
	memset(head,-1,sizeof(head));
	m.clear();
	st=0; et=M-1;//起點,終點 
	for(i=0;i<n;i++){
		scanf("%s",str);
		m[str]=tot++;
		add(m[str],et,1);
	}
	
	scanf("%d",&t);
	for(i=0;i<t;i++){
		scanf("%s %s",str,ch);
		m[str]=tot++;
		if(!m[ch])  m[ch]=tot++;
		add(st,m[str],1);
		add(m[str],m[ch],1);	
	}
	scanf("%d",&k);
	for(i=0;i<k;i++){
		scanf("%s %s",str,ch);
		if(!m[str]) m[str]=tot++;
		if(!m[ch]) m[ch]=tot++;
		add(m[str],m[ch],inf);
 	}
	int ans=0;
	while(bfs()){
		ans+=dinic(st,inf);
	}
	printf("%d\n",t-ans);
	return 0;
} 


poj 1087 A Plug for UNIX(字符串編號建圖)