1. 程式人生 > >hdu 1039 Easier Done Than Said?

hdu 1039 Easier Done Than Said?

至少 -m problem this earch acc develop cpp article

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1039

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10919 Accepted Submission(s): 5270

Problem Description Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it‘s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee‘ or ‘oo‘.

(For the purposes of this problem, the vowels are ‘a‘, ‘e‘, ‘i‘, ‘o‘, and ‘u‘; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end‘ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

Sample Output
<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.

Source Mid-Central USA 2000
Recommend We have carefully selected several similar problems for you: 1062 1073 1043 1088 1113 題目大意:這個題目主要是對字符串進行處理。詳細有三個要求:1、至少存在一個元音 2、不能出現連續兩個同樣的字母。除了oo和ee 3、不能出現三個連續的元音,也不能出現三個連續的輔音。


詳見代碼。

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

int num[30]={0};

int main()
{
    num[‘a‘-‘a‘]=1;
    num[‘e‘-‘a‘]=1;
    num[‘i‘-‘a‘]=1;
    num[‘o‘-‘a‘]=1;
    num[‘u‘-‘a‘]=1;
    char str[5000];
    while(~scanf("%s",&str),strcmp(str,"end")!=0)
    {
        int s=0;
        int flag=0;
        int len=strlen(str);
        for(int i=0;i<len;i++)
        {
            if(num[str[i]-‘a‘]==1)
                s++;
            if(i>0)
            if(str[i]!=‘o‘&&str[i]!=‘e‘&&str[i]==str[i-1])
                flag=1;
            if(i>1)
            if(num[str[i]-‘a‘]==num[str[i-1]-‘a‘]&&num[str[i]-‘a‘]==num[str[i-2]-‘a‘])
                flag=1;
        }
        if(s==0)flag=1;
        if(flag==0)
        printf("<%s> is acceptable.\n",str);
        else
            printf("<%s> is not acceptable.\n",str);
    }
    return 0;
}

hdu 1039 Easier Done Than Said?