1. 程式人生 > >Hdu 1008 Elevator

Hdu 1008 Elevator

total multi cost sub int start cep ota com ecif

Elevator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 72304 Accepted Submission(s): 39764

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2

3 2 3 1

0

Sample Output

17

41

#include<stdio.h>int main()
{
    int n;
    int start,a;
    int t;
    int i;
    while(scanf("%d",&n),n)
    {
        t=0;start=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            if(a>start)t+=6*(a-start);
            else t+=4*(start-a);
            t+=5;
            start=a;
        }
        printf("%d\n",t);
    }    
    return 0; 
}  

  

Hdu 1008 Elevator