1. 程式人生 > >字典樹("strcmp()" Anyone? uva11732)

字典樹("strcmp()" Anyone? uva11732)

pre call solution only notes take printf when 計算

strcmp() is a library function in C/C++ which compares two strings. It takes two strings as input
parameter and decides which one is lexicographically larger or smaller: If the first string is greater then
it returns a positive value, if the second string is greater it returns a negative value and if two strings

are equal it returns a zero. The code that is used to compare two strings in C/C++ library is shown
below:
Figure: The standard strcmp() code provided for this problem.
The number of comparisons required to compare two strings in strcmp() function is never returned
by the function. But for this problem you will have to do just that at a larger scale. strcmp() function
continues to compare characters in the same position of the two strings until two different characters
are found or both strings come to an end. Of course it assumes that last character of a string is a null
(‘\0’) character. For example the table below shows what happens when \than" and \that"; \therE"
and \the" are compared using strcmp() function. To understand how 7 comparisons are needed in
both cases please consult the code block given above.
Input
The input file contains maximum 10 sets of inputs. The description of each set is given below:
Each set starts with an integer N (0 < N < 4001) which denotes the total number of strings. Each
of the next N lines contains one string. Strings contain only alphanumerals (‘0’...‘9’, ‘A’...‘Z’, ‘a’...‘z’)
have a maximum length of 1000, and a minimum length of 1.
Input is terminated by a line containing a single zero.
Output
For each set of input produce one line of output. This line contains the serial of output followed by
an integer T . This T denotes the total number of comparisons that are required in the strcmp()
function if all the strings are compared with one another exactly once. So for N strings the function
strcmp() will be called exactly N(N2-1) times. You have to calculate total number of comparisons
inside the strcmp() function in those N(N2-1) calls. You can assume that the value of T will fit safely
in a 64-bit signed integer. Please note that the most straightforward solution (Worst Case Complexity
O(N 2 1000)) will time out for this problem.
Sample Input
2 a b 4
cat
hat
mat
sir
0
Sample Output
Case 1: 1
Case 2: 6

trie的裸題,但是本題要用左兒子右兄弟的方法來儲存樹,還有就是計算的時候有些細節要註意。

#include<bits/stdc++.h>
#define maxn 5000000
#define next Nxet
using namespace std;
int tot[maxn],head[maxn],next[maxn];//tot表示葉節點的數量,head左,next右 
char ch[maxn];
int sz=1;
long long n,ans=0;
void insert(char* s)
{
	int u=0,len=strlen(s);
	tot[0]++;
	for(int i=0;i<=len;i++)
	{
		bool ok=false;
		int v;
		for(v=head[u];v;v=next[v])
			if(ch[v]==s[i])
				{ok=1;break;}
		if(!ok)//註意這裏細節 
		{
			v=sz++;
			tot[v]=0;
			ch[v]=s[i];
			next[v]=head[u];
			head[u]=v;
			head[v]=0;
		}
		u=v;
		tot[u]++;
	}
}

void clear()
{
	sz=1;tot[0]=head[0]=next[0]=0;
	memset(ch,0,sizeof(ch));
}

void query(int depth,int u)
{
	if(head[u]==0) 	ans+=tot[u]*(tot[u]-1)*depth;//如果是葉節點,就是所有的選擇乘上深度 
	else
	{
		int sum=0;
		for(int i=head[u];i;i=next[i])//乘法原理 
			sum+=tot[i]*(tot[u]-tot[i]);
		ans+=sum/2*(2*depth+1);//算重復了/2 
		for(int i=head[u];i;i=next[i])
			query(depth+1,i);
	}
}
char s[maxn];
int main()
{
	int kase=1; 
	while(cin>>n&&n)
	{
		clear();
		while(n--)
		{
			cin>>s;
			insert(s);
		}
		ans=0;
		query(0,0);
		printf("Case %d: %lld\n",kase++,ans);	
	}
	return 0;
} 

字典樹("strcmp()" Anyone? uva11732)