1. 程式人生 > >poj3311Hie with the Pie

poj3311Hie with the Pie

bsp wid pan sel scan namespace names like val

Hie with the Pie
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7599 Accepted: 4088

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n

). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i
to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

East Central North America 2006 題意:求從點0出發經過其他所有點再回到0的最短路徑

分析:很經典的狀壓dp問題,不過我當時狀態想錯了,以為用一維就可以表示,這樣導致的後果就是可以直接從一個點跳到另一個毫不相幹的點上去,事實上,我們需要用二維表示狀態,設dp[s][i]表示狀態s的情況下最終走到i的最短距離,s是一串二進制串,每一位表示是否經過第i個點,狀態轉移方程很容易看出來,我們可以這樣分析:另取一個已經經過的點j,如果我們要達到i,我們可以用沒經過i的狀態但已經走到j的狀態,加上i到j的距離更新,具體看代碼:

#include <cstring>
#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;

int n, d[15][15], dp[1 << 12][12], ans;

int main()
{
    while (scanf("%d", &n) && n != 0)
    {
        for (int i = 0; i <= n; i++)
            for (int j = 0; j <= n; j++)
                scanf("%d", &d[i][j]);
        for (int k = 0; k <= n; k++)
            for (int i = 0; i <= n; i++)
                for (int j = 0; j <= n; j++)
                    if (d[i][k] + d[k][j] < d[i][j])
                        d[i][j] = d[i][k] + d[k][j];
        for (int s = 0; s <= (1 << n) - 1; s++)
        {
            for (int i = 1; i <= n; i++)
            {
                if (s & (1 << (i - 1)))
                {
                    if (s == (1 << (i - 1)))
                        dp[s][i] = d[0][i];
                    else
                    {
                        dp[s][i] = 1000000000;
                        for (int j = 1; j <= n; j++)
                            if ((s & (1 << (j - 1))) && i != j)
                                dp[s][i] = min(dp[s][i], dp[s ^ (1 << (i - 1))][j] + d[j][i]);
                    }
                }
            }
        }
        ans = 1000000000;
        for (int i = 1; i <= n; ++i)
            ans = min(dp[(1 << n) - 1][i] + d[i][0], ans);
        printf("%d\n", ans);
    }

    return 0;
}

poj3311Hie with the Pie