1. 程式人生 > >HPU 1002 A + B Problem II【大數】

HPU 1002 A + B Problem II【大數】

lar 保存 memory positive test size mod ack auth

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 261413 Accepted Submission(s): 50581


Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author Ignatius.L

思路:

將數字以字符的形式存儲到字符數組中,由於在存儲的時候是高位在以0為下標的下標變量中存儲的。所以要將其進行翻轉,存儲到整形數組中(也就是高位存儲到大下標變量中。由於在進位的時候能在原來的基礎上進行i++。來存儲最高位的數據)。然後將兩個大數按位相加。假設比十大,進行進位操作!

代碼:

#include <stdio.h>
#include <string.h>
#define N 10005
char a[N],b[N];
int c[N],d[N];
int main()
{
	int n,i,j,k,len1,len2;
	scanf("%d",&n);
	k=n;
	while(n--)
	{
		memset(c,0,sizeof(c));//每次都得清零,所以得放到while循環裏面。 
	    memset(d,0,sizeof(d));
		getchar();
		scanf("%s%s",a,b);//空格也是scanf的切割符! 
		len1=strlen(a);
		len2=strlen(b);
		for(i=len1-1,j=0;i>=0;i--)//由於須要逆序保存,所以應該設變量j從0開始!

c[j++]=a[i]-'0'; for(i=len2-1,j=0;i>=0;i--) d[j++]=b[i]-'0'; for(i=0;i<1001;i++) { c[i]+=d[i]; if(c[i]>=10) { c[i]-=10; c[i+1]++; } } printf("Case %d:\n%s + %s = ",k-n,a,b); for(i=1000;i>=0&&c[i]==0;i--); if(i>=0) for(;i>=0;i--) { printf("%d",c[i]); } else printf("0"); printf("\n"); if(n!=0) printf("\n"); } return 0; }


HPU 1002 A + B Problem II【大數】