1. 程式人生 > >poj 3267 The Cow Lexicon (動態規劃)

poj 3267 The Cow Lexicon (動態規劃)

input mil sys 裏的 single ont n-1 ret map

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8167 Accepted: 3845

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a‘..‘z‘. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a‘..‘z‘) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3..W+2: The cows‘ dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2
dp[i]代表以i為結尾的最優選擇,狀態轉移方程為:

dp[i]=min(dp[i-1]+1,opt); opt:包括第 i個字符的最優選擇;

把原先的字典裏的詞組反轉,枚舉字典裏的全部詞匯,找到最優解。

#include<stdio.h>
#include<queue>
#include<map>
#include<string>
#include<string.h>
using namespace std;
#define N 305
const int inf=0x1f1f1f1f;
char str[N*2][30],s[N];
int dp[N];
int main()
{
    int i,j,k,n,m;
    char ch;
    while(scanf("%d%d",&m,&n)!=-1)
    {
        scanf("%s",s+1);
        for(i=0;i<m;i++)
        {
            scanf("%s",str[i]);
            int len=strlen(str[i]);  //字符串反轉
            for(j=0;j<len/2;j++)
            {
                ch=str[i][j];
                str[i][j]=str[i][len-j-1];
                str[i][len-1-j]=ch;
            }
            str[i][len]='\0';
        }
        dp[0]=0;
        int tmp;
        for(i=1;i<=n;i++)
        {
            tmp=dp[i-1]+1;  //tmp初始化為該字符舍去時的值
            for(j=0;j<m;j++)
            {
                if(str[j][0]!=s[i])      
                    continue;
                int l=1,len=strlen(str[j]);
                for(k=i-1;k>0&&l<len;k--)  //尋找該單詞出現的最早位置
                {
                    if(s[k]==str[j][l])
                        l++;
                }
                if(l==len)      //包括此單詞
                    tmp=min(tmp,dp[k]+(i-k-len));
            }
            dp[i]=tmp;
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}





poj 3267 The Cow Lexicon (動態規劃)