1. 程式人生 > >2014ACM/ICPC亞洲區域賽牡丹江站現場賽-I ( ZOJ 3827 ) Information Entropy

2014ACM/ICPC亞洲區域賽牡丹江站現場賽-I ( ZOJ 3827 ) Information Entropy

esp osi mos wid integer blank border amount 什麽

Information Entropy

Time Limit: 2 Seconds Memory Limit: 65536 KB Special Judge

Information Theory is one of the most popular courses in Marjar University. In this course, there is an important chapter about information entropy.

Entropy is the average amount of information contained in each message received. Here, a message stands for an event, or a sample or a character drawn from a distribution or a data stream. Entropy thus characterizes our uncertainty about our source of information. The source is also characterized by the probability distribution of the samples drawn from it. The idea here is that the less likely an event is, the more information it provides when it occurs.

Generally, "entropy" stands for "disorder" or uncertainty. The entropy we talk about here was introduced by Claude E. Shannon in his 1948 paper "A Mathematical Theory of Communication". We also call it Shannon entropy or information entropy to distinguish from other occurrences of the term, which appears in various parts of physics in different forms.

Named after Boltzmann‘s H-theorem, Shannon defined the entropy Η (Greek letter Η, η) of a discrete random variable X with possible values {x1, x2, ..., xn} and probability mass functionP(X) as:

H(X)=E(?ln(P(x)))

Here E is the expected value operator. When taken from a finite sample, the entropy can explicitly be written as

H(X)=?i=1nP(xi)log b(P(xi))

Where b is the base of the logarithm used. Common values of b are 2, Euler‘s number e, and 10. The unit of entropy is bit for b = 2, nat for b = e, and dit (or digit) for b = 10 respectively.

In the case of P(xi) = 0 for some i, the value of the corresponding summand 0 logb(0) is taken to be a well-known limit:

0log b(0)=limp0+plog b(p)

Your task is to calculate the entropy of a finite sample with N values.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100) and a string S. The string S is one of "bit", "nat" or "dit", indicating the unit of entropy.

In the next line, there are N non-negative integers P1, P2, .., PN. Pi means the probability of the i-th value in percentage and the sum of Pi will be 100.

Output

For each test case, output the entropy in the corresponding unit.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

3
3 bit
25 25 50
7 nat
1 2 4 8 16 32 37
10 dit
10 10 10 10 10 10 10 10 10 10

Sample Output

1.500000000000
1.480810832465
1.000000000000

Author: ZHOU, Yuchen
Source: The 2014 ACM-ICPC Asia Mudanjiang Regional Contest



題目鏈接:

problemId=5381">Information Entropy



解題思路:又是一道簽到題!!!當時想多了。竟然糾結在積分上,果真是想多了,根本不須要什麽技術,就是依照那個數學公式算。又學到了個小方法。表示對數能夠用log(m, n)= log(n) / log(m). 還有就是e = exp(1)。

還有就是註意當p = 0時,函數值為0。



AC代碼:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
#define INF 0x7fffffff

#define e exp(1.0)

int main()
{
    #ifdef sxk
        freopen("in.txt","r",stdin);
    #endif
    int T, n, p;
    string s;
    scanf("%d",&T);
    while(T--)
    {
        double ans = 0;
        scanf("%d",&n);
        cin>>s;
        if(s == "bit"){
            for(int i=0; i<n; i++){
                scanf("%d", &p);
                if(p)
                    ans += -(p/100.0*log(p/100.0)/log(2));
            }
        }
        else if(s == "nat"){
            for(int i=0; i<n; i++){
                scanf("%d", &p);
                if(p)
                    ans += -(p/100.0*log(p/100.0)/log(e));
            }
        }
        else{
            for(int i=0; i<n; i++){
                scanf("%d", &p);
                if(p)
                    ans += -(p/100.0*log(p/100.0)/log(10));
            }
        }
        printf("%.14lf\n",ans);
    }
    return 0;
}





2014ACM/ICPC亞洲區域賽牡丹江站現場賽-I ( ZOJ 3827 ) Information Entropy