1. 程式人生 > >HDU1306 String Matching 【暴力】

HDU1306 String Matching 【暴力】

mea pro cas courier ace easy pes ring series

String Matching

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 847 Accepted Submission(s): 434

Problem Description It‘s easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:

CAPILLARY
MARSUPIAL

There is only one common letter (A). Better is the following overlay:

CAPILLARY
MARSUPIAL

with two common letters (A and R), but the best is:

CAPILLARY
MARSUPIAL

Which has three common letters (P, I and L).

The approximation measure appx(word1, word2) for two words is given by:

common letters * 2
-----------------------------
length(word1) + length(word2)

Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.

Sample Input
The input for your program will be a series of words, two per line, until the end-of-file flag of -1.

Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. For example:

CAR CART
TURKEY CHICKEN
MONEY POVERTY
ROUGH PESKY
A A
-1

The words will all be uppercase.

Sample Output
Print the value for appx() for each pair as a reduced fraction, like this:

appx(CAR,CART) = 6/7
appx(TURKEY,CHICKEN) = 4/13
appx(MONEY,POVERTY) = 1/3
appx(ROUGH,PESKY) = 0
appx(A,A) = 1

#include <stdio.h>
#include <string.h>
#define maxn 1002
char s1[maxn], s2[maxn];
int len1, len2, ans, len;

void appx(){
	int num;
	int begin1 = 0, begin2 = len2 - 1;
	while(begin2 >= 0){
		num = 0;
		int i = begin1, j = begin2;
		while(i < len1 && j < len2){
			if(s1[i++] == s2[j++]) ++num;
		}
		if(num > ans) ans = num;
		--begin2;
	}
	begin2 = begin1 = 0;
	while(begin1 < len1){
		num = 0;
		int i = begin1, j = begin2;
		while(i < len1 && j < len2){
			if(s1[i++] == s2[j++]) ++num;
		}
		if(num > ans) ans = num;
		++begin1;
	}
}
int gcd(int i, int j){
	return !j ? i : gcd(j, i % j);
}
void huajian(){
	int t = gcd(ans, len);
	ans /= t; len /= t;
}

int main(){
	while(scanf("%s", s1), s1[0] != '-'){
		scanf("%s", s2);
		len1 = strlen(s1);
		len2 = strlen(s2);
		ans = 0;
		appx();
		len = len1 + len2;
		ans *= 2;
		printf("appx(%s,%s) = ", s1, s2);
		if(ans == 0 || ans == len){
			printf("%d\n", ans / len);
			continue;
		}
		huajian();
		printf("%d/%d\n", ans, len);
	}
	return 0;
}


HDU1306 String Matching 【暴力】