1. 程式人生 > >HDOJ 1217 Arbitrage(擬最短路,floyd算法)

HDOJ 1217 Arbitrage(擬最短路,floyd算法)

same double script strong ram tar per bre center

Arbitrage

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5679 Accepted Submission(s): 2630


Problem Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output
Case 1: Yes
Case 2: No
題意: 套匯是指利用不同外匯市場的外匯差價。在某一外匯市場上買進某種貨幣,同一時候在還有一外匯市場上賣出該種貨幣。以賺取利潤。這樣的利潤稱之為套利。

比方1美元能夠買0.5英鎊。而1英鎊能夠買10法郎,1法郎能夠買0.21美那麽可用通過套匯使用1美元買到1.05美元,套利是存在的。以下給出各個貨幣的種類和名稱,再給出一些貨幣兌換的匯率。請問是否存在套利?

解題思路:能夠看做最短路問題,只是權值的計算是乘而不是相加。而與小於1的權值相乘會導致權值減小,即存在負權值問題。 所以此題不能用dijkstra算法,此題能夠用floyd算法。 代碼例如以下:
<span style="font-size:12px;">#include<cstdio>
#include<cstring>
#define maxn 32
double map[maxn][maxn];
int n,t;

void floyd()
{
	int i,j,k;
	for(k=0;k<n;++k)
	{
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;++j)
			{
				if(map[i][j]<map[i][k]*map[k][j])
				   map[i][j]=map[i][k]*map[k][j];
			}
		}
	}
	int sign=0;
	for(i=0;i<n;++i)
	{
		if(map[i][i]>1)//自身的匯率為1。若匯率大於1則說明能套匯 
		{
			sign=1;
			break;
		}  
	}
	if(sign)
	   printf("Yes\n");
	else 
	   printf("No\n");
}

int main()
{
	int m,i,j,a,b,t=1;;
	double c;
	char str[32][32],s1[32],s2[32];
	while(scanf("%d",&n)&&n)
	{
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;++j)
				map[i][j]=0;
		}
		for(i=0;i<n;++i)
			scanf("%s",str[i]);
		scanf("%d",&m);
		while(m--)
		{
			scanf("%s%lf%s",s1,&c,s2);
			for(i=0;i<n;++i)
			{
				if(strcmp(s1,str[i])==0)
					a=i;
				if(strcmp(s2,str[i])==0)
					b=i;
			}
			map[a][b]=c;
		}
		printf("Case %d: ",t++);
		floyd();
	}
	return 0;
}</span>


HDOJ 1217 Arbitrage(擬最短路,floyd算法)