1. 程式人生 > >HDU 1198 Farm Irrigation(並查集+位運算)

HDU 1198 Farm Irrigation(並查集+位運算)

another org des clas accepted som using red wan

Farm Irrigation

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 38 Accepted Submission(s) : 24

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

技術分享

Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like

技術分享

Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A‘ to ‘K‘, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

Author

ZHENG, Lu

Source

Zhejiang University Local Contest 2005

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<set>
using namespace std;
int mp[11]={9,3,12,6,5,10,11,13,14,7,15};
  //表示一種狀態,B(1<<0)+(1<<1)=3:表示上右是通的.
int dr[4][2]={{-1,0},{0,1},{1,0},{0,-1} };// 上,右,下,左
int n,m;
char ch[110][110];
int fa[110*110];
bool ok(int x,int y)
{
    if (x<0 || x>=n) return 0;
    if (y<0 || y>=m) return 0;
    return 1;
}
int findfa(int k)
{
    if (fa[k]==k) return k;
     else return fa[k]=findfa(fa[k]);
}
int main()
{

    while(~scanf("%d%d",&n,&m))
    {
       if (n<0 || m<0) break;
       for(int i=0;i<n;i++)
         scanf("%s",&ch[i]);

       for(int i=0;i<n*m;i++)   fa[i]=i;

       for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
       {
          for(int k=1;k<3;k++) //向右,向下兩個方向
          {
              int x=i+dr[k][0];
              int y=j+dr[k][1];
              if (!ok(x,y)) continue;
              if (   (mp[ch[i][j]-A]&(1<<k))==0 ||  (mp[ch[x][y]-A]&(1<<((k+2)%4)))==0   ) continue;
              int fx=findfa(i*m+j);   //之前一直錯,問題在這裏應該是*m而不是n。
              int fy=findfa(x*m+y);
              if (fx!=fy) fa[fx]=fy;
          }

       }

       int sum=0;
       for(int i=0;i<n*m;i++) if (fa[i]==i) sum++;
       printf("%d\n",sum);
    }
    return 0;
}

HDU 1198 Farm Irrigation(並查集+位運算)