1. 程式人生 > >[ACM] hdu 1029 Ignatius and the Princess IV (動歸或hash)

[ACM] hdu 1029 Ignatius and the Princess IV (動歸或hash)

inner other for each sam 代碼 test case break accep bre

Ignatius and the Princess IV

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32767K (Java/Other)
Total Submission(s) : 7 Accepted Submission(s) : 3

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output

3
5
1

Author

Ignatius.L

解題思路:

給出n個數。n為奇數。求在裏面至少出現(n+1)/2 次的那個數。

方法一:

同等消除。比方數 -1 -2 3 3 3 -2 ,消除一次-1 3 -2 去掉。剩余3 3 -2 。再消除一次 剩余3,3就是所求。

代碼:

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

int main()
{
    int n;
    int num,cnt,r;
    while(scanf("%d",&n)!=EOF)//一定得寫上。EOF 
    {
        cnt=0;
        while(n--)
        {
            scanf("%d",&num);
            if(cnt==0)
            {
                r=num;
                cnt=1;
            }
            if(num==r)
                cnt++;
            else
                cnt--;

        }
        printf("%d\n",r);
    }
    return 0;
}


方法二:hash打表。

代碼:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=1000005;
int hash[maxn];

int main()
{
    int n,num,r;
    while(scanf("%d",&n)!=EOF)
    {
        memset(hash,0,sizeof(hash));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num);
            hash[num]++;
            if(hash[num]>n/2)
            {
                r=num;//找到了也不能break掉。由於有可能還沒有輸入完成
            }
        }
        printf("%d\n",r);
    }
    return 0;
}


[ACM] hdu 1029 Ignatius and the Princess IV (動歸或hash)