1. 程式人生 > >poj2236 Wireless Network 並查集簡單應用

poj2236 Wireless Network 並查集簡單應用

scan 代碼 space win worker compute stdlib.h else ++

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not. Sample
Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output

FAIL
SUCCESS

題意:

  一張圖上分布著n臺壞了的電腦,並知道它們的坐標。兩臺修好的電腦如果距離<=d就可以聯網,也可以通過其他修好的電腦間接相連。給出操作“O x”表示修好x,給出操作“S x y”,請你判斷x和y在此時有沒有連接上。

思路:

  並查集的簡單應用,將修好的做一下標記,修好一臺,與每一臺做了標記的遍歷檢查,遍歷時要加上距離這個判斷條件。

代碼:

#include<iostream>
#include<stack>
#include<queue>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
using namespace std;
int pre[20010];
int logo[20010];
struct  node
{
    int x;
    int y;
} edge[40010];
int find(int x)
{
    if(x!=pre[x])
        pre[x]=find(pre[x]);
    return pre[x];
}
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        pre[fy]=fx;
    }
}
double dis(struct  node a,struct  node b)//求兩點之間的距離
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main()
{
    int n;
    double maxdis;
    cin>>n>>maxdis;
    for(int i=1; i<=n; i++)
    {
        cin>>edge[i].x>>edge[i].y;
    }
    for(int i=1; i<=n; i++)
    {
        pre[i]=i;
        logo[i]=0;
    }
    char ch;
    while(~scanf("%c",&ch))
    {
        int x,y;
        if(ch==O)
        {
            cin>>x;
            logo[x]=1;//修好的標記為1
            for(int i=1; i<=n; i++)
            {
                if((dis(edge[i],edge[x])<=maxdis)&&logo[i]==1)//如果修好了,並且距離不大於規定距離,則可以並
                    merge(i,x);
            }
        }
        if(ch==S)
        {
            cin>>x>>y;
            if(find(x)==find(y))
                cout<<"SUCCESS"<<endl;
            else
                cout<<"FAIL"<<endl;
        }
    }
}

poj2236 Wireless Network 並查集簡單應用