1. 程式人生 > >POJ 2376 Cleaning Shifts(貪心)

POJ 2376 Cleaning Shifts(貪心)

des always == col contain print eight ide weight

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

最小代價的區間覆蓋。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<map>
using namespace std;
typedef long long LL;
const int maxn=25000+100;
struct node{
    int st,ed;
}e[maxn];
int n,m;
int cmp(node l1,node l2)
{
    if(l1.st==l2.st)
        return  l1.ed>l2.ed;
    return l1.st<l2.st;
}
int main()
{
    int ed,temp;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&e[i].st,&e[i].ed);
        sort(e,e+n,cmp);
        if(e[0].st!=1)
        {
            printf("-1\n");
            continue;
        }
        int ans=1;
        ed=e[0].ed;
        temp=0;
        for(int i=1;i<n;i++)
        {
            if(e[i].st>ed+1)
            {
                ed=temp;
                ans++;
            }
            if(e[i].st<=ed+1)
            {
                if(e[i].ed>temp)
                    temp=e[i].ed;
                if(e[i].ed==m)
                {
                    ans++;
                    ed=m;
                    break;
                }
            }
        }
        if(ed==m)   printf("%d\n",ans);
        else   printf("-1\n");
    }
    return 0;
}


POJ 2376 Cleaning Shifts(貪心)