1. 程式人生 > >Oil Deposits DFS FloodFill漫水填充法求連通塊問題

Oil Deposits DFS FloodFill漫水填充法求連通塊問題

with this ron reg row led one 個數 ret

Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or [email protected]
/* */, representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2


搜索水題。枚舉每個起始點,向外擴展與他相鄰的點。起始點的個數即為連通塊個數。


#include<stdio.h>

char a[105][105];
int c,n,m;
void dfs(int x,int y){
    if(x<0||y<0||x>=n||y>=m) return;
    if(a[x][y]==*) return;
    if(a[x][y]==@){
        a[x][y]=*;
        dfs(x+1,y);
        dfs(x+1,y+1);
        dfs(x,y+1);
        dfs(x-1,y+1);
        dfs(x-1,y);
        dfs(x-1,y-1);
        dfs(x,y-1);
        dfs(x+1,y-1);
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m)&&!(n==0&&m==0)){
        c=0;
    for(i=0;i<n;i++){
        getchar();
        scanf("%s",a[i]);
    }
    for(i=0;i<n;i++){
        for(j=0;j<m;j++){
            if(a[i][j]==@){
                c++;
                dfs(i,j);
            }
        }
    }
    printf("%d\n",c);
    }
    return 0;
} 

Oil Deposits DFS FloodFill漫水填充法求連通塊問題