1. 程式人生 > >POJ 1141 Brackets Sequence (區間DP)

POJ 1141 Brackets Sequence (區間DP)

ive bsp rip mes character har typedef som memset

Description

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters ‘(‘, ‘)‘, ‘[‘, and ‘]‘ is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters ‘(‘, ‘)‘, ‘[‘ and ‘]‘) that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]


題意:給一串括號序列。依照合法括號的定義,加入若幹括號,使得序列合法。

典型區間DP。設dp[i][j]為從i到j須要加入最少括號的數目。

dp[i][j] = max{ dp[i][k]+dp[k+1][j] } (i<=k<j)

假設s[i] == s[j] , dp[i][j] 還要和dp[i+1][j-1]比較。 枚舉順序依照區間長度枚舉。

由於要求輸出合法序列,就要記錄在原序列在哪些位置進行了添加,設c[i][j]為從i到j的 添加括號的位置,假設不須要添加。那麽c[i][j] 賦為-1,打印時僅僅需遞歸打印就可以。


#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
typedef long long LL;
const int MAX=0x3f3f3f3f;
int n,c[105][105],dp[105][105];
char s[105];
void print(int i,int j) {
    if( i>j ) return ;
    if( i == j ) {
        if(s[i] == '(' || s[i] == ')') printf("()");
        else printf("[]");
        return ;
    }
    if( c[i][j] > 0 ) {  // i到j存在添加括號的地方,位置為c[i][j]
        print(i,c[i][j]);
        print(c[i][j]+1,j);
    } else {
        if( s[i] == '(' ) {
            printf("(");
            print(i+1,j-1);
            printf(")");
        } else {
            printf("[");
            print(i+1,j-1);
            printf("]");
        }
    }
}
void DP() {   //區間DP
    for(int len=2;len<=n;len++)
        for(int i=1;i<=n-len+1;i++) {
            int j = i+len-1;
            for(int k=i;k<j;k++) if( dp[i][j] > dp[i][k]+dp[k+1][j] ) {
                dp[i][j] = dp[i][k] + dp[k+1][j];
                c[i][j] = k;  // 記錄斷開的位置
            }
            if( ( s[i] == '(' && s[j] == ')' || s[i] == '[' && s[j] == ']' ) && dp[i][j] > dp[i+1][j-1] ) {
                dp[i][j] = dp[i+1][j-1];
                c[i][j] = -1;  //i到j不須要斷開。由於dp[i+1][j-1]的值更小,上面枚舉的k位置都比這個大。所以不再斷開
            }
        }
}
int main()
{
    scanf("%s",s+1);
    n = strlen(s+1);
    memset(c,-1,sizeof(c));
    memset(dp,MAX,sizeof(c));
    for(int i=1;i<=n;i++) dp[i][i] = 1, dp[i][i-1] = 0; //賦初值
    DP();
    print(1,n);
    printf("\n");
    return 0;
}





POJ 1141 Brackets Sequence (區間DP)