1. 程式人生 > >poj 2096 Collecting Bugs 【概率DP】【逆向遞推求期望】

poj 2096 Collecting Bugs 【概率DP】【逆向遞推求期望】

tdi cor ros quick -a sim total 3.0 pla

Collecting Bugs
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 3523 Accepted: 1740
Case Time Limit: 2000MS Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It‘s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan‘s opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan‘s work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan‘s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000


題意:一個軟件有S個系統。但會產生N種bug。一個人一天能夠發現一個bug,這個bug既屬於某一個系統。又屬於某一個分類。每一個bug屬於某個系統的概率是1/S,屬於某種分類的概率是1/N。如今問你發現N種bug且S個系統都發現bug的天數的期望。



思路:用dp[i][j]表示發現i種bug且j個系統都發現bug的天數的期望。能夠得到4種狀態


1。dp[i][j]—— 新bug 既屬於已發現bug的種類。又屬於已經發現bug的系統。則有概率 (i / S) * (j / N)

2。dp[i+1][j]—— 新bug 不屬於已發現bug的種類,屬於已經發現bug的系統。則有概率 (1 - i / N) * (j / S)

3。dp[i][j+1]—— 新bug 屬於已發現bug的種類,不屬於已經發現bug的系統。則有概率 (i / N) * (1 - j / S)

4,dp[i+1][j+1]—— 新bug 既不屬於已經發現bug的種類,也不屬於已經發現bug的系統。

則有概率 (1 - i / N) * (1 - j / S)


求期望倒著遞推,由dp[N][S] = 0 退出 dp[0][0]就可以。註意推導時 全是浮點型。



AC代碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[1010][1010];
int main()
{
    int N, S;
    while(scanf("%d%d", &N, &S) != EOF)
    {
        memset(dp, 0, sizeof(dp));
        for(int i = N; i >= 0; i--)
        {
            for(int j = S; j >= 0; j--)
            {
                if(i == N && j == S) continue;
                double x = i, y = j;
                double p1 = dp[i+1][j] * (y / S) * (1 - x / N);
                double p2 = dp[i][j+1] * (x / N) * (1 - y / S);
                double p3 = dp[i+1][j+1] * (1 - y / S) * (1 - x / N);
                double p0 = 1 - (x / N) * (y / S);
                dp[i][j] = (p1 + p2 + p3 + 1) / p0;
            }
        }
        printf("%.4lf\n", dp[0][0]);
    }
    return 0;
}



poj 2096 Collecting Bugs 【概率DP】【逆向遞推求期望】