1. 程式人生 > >Dungeon Master (三維BFS)

Dungeon Master (三維BFS)

follow 題目 not making clas ont orm 出發 nes

題目:

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.



Is an escape possible? If yes, how long will it take?
Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#‘ and empty cells are represented by a ‘.‘. Your starting position is indicated by ‘S‘ and the exit by the letter ‘E‘. There‘s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

題意:
相當於一棟大樓裏面很多秘密通道,S是起始位置,E是終點位置,‘#’是墻,‘.’是路,問從S出發最少經過多長時間就到達E處;

分析:
和迷宮不同的是,迷宮是平面上東南西北的移動,相當於在大樓裏面的一層樓裏找出口,而這個題目在迷宮的基礎上又增加了上下的移動,即大樓裏面的上下層之間的移動,
所以需要建立三維的數組,找到S的位置,移動方向由4個增加到6個,直到找到E為止,如果找遍了所有的能走的地方都沒找到出口E,就出不來了!!!

AC代碼:
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<string>
using namespace std;
char a[35][35][35];
int  b[35][35][35];
int L,R,C;
int f[3][6]={{1,-1,0, 0,0, 0},
          {0, 0,1,-1,0, 0},
          {0, 0,0, 0,1,-1}};
int s2[35][35][35];
int flag;
struct Knot
{
    int x,y,z;
    int step;
};
Knot c,d;
bool search1(int x,int y,int z)
{
    return (x>=1&&x<=L&&y>=1&&y<=R&&z>=1&&z<=C);
}
int bfs(int si,int sj,int sk)
{
    queue<Knot>s;
    c.x=si;
    c.y=sj;
    c.z=sk;
    c.step=0;
    s.push(c);
    while (!s.empty())
    {
        d=s.front();
        s.pop();
        c.step=d.step+1;
        for (int i=0;i<6;i++)
         {
             c.x=d.x+f[0][i];
             c.y=d.y+f[1][i];
             c.z=d.z+f[2][i];
             if (search1(c.x,c.y,c.z)&&!b[c.x][c.y][c.z]&&a[c.x][c.y][c.z]!=#)
             {
                 if (a[c.x][c.y][c.z]==E)
                 return c.step;
                    b[c.x][c.y][c.z]=1;
                    s.push(c);
             }
         }
    }
    return -1;
}
int main()
{
    int i,j,k;
    int si,sj,sk;
    while (cin>>L>>R>>C&&(L!=0||R!=0||C!=0))
    {
        memset(b,0,sizeof(b));
        for (i=1;i<=L;i++)
            for (j=1;j<=R;j++)
              for (k=1;k<=C;k++)
          {
            cin>>a[i][j][k];
            if (a[i][j][k]==S)
                {
                    si=i;
                    sj=j;
                    sk=k;
                }
          }
          flag=bfs(si,sj,sk);
          if (flag==-1)
            cout << "Trapped!" << endl;
          else
             cout << "Escaped in " << flag << " minute(s)." << endl;

    }
    return 0;
}

Dungeon Master (三維BFS)