1. 程式人生 > >POJ - 3104 :Drying

POJ - 3104 :Drying

program containe ever form 分法 write fast 減少 small

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3
sample output #2 2

有n件衣服,其含水量給出,不做處理單位時間可減少一含水量,有且僅有一個烘幹機可以單位時間減少k含水量,求將所有衣服弄幹的最短時間,用二分法。
對於每一個中間值,枚舉每個衣服,小於x則自然風幹,大於x能用烘衣機一段時間再自然風幹使其時間等於x。

#include<iostream>
#include<string.h>
#include<cmath>

using namespace std;

long long a[100005];

int main() {
int n;
while(cin>>n)
{
long long max=-1;
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
cin>>a[i];
if(a[i]>max)
max=a[i];
}
long long k;
cin>>k;
long long low=1,hign=max,mid;
if(k!=1)
{

while(hign-low>1)
{
mid=(low+hign)/2;
long long time=0;
for(int i=0;i<n;i++)
{
if(a[i]>mid)
time=time+(a[i]-mid +k-2)/ (k-1);
}
if(time>mid)
low=mid+1;
else
hign=mid;
}

mid=(low+hign)/2;
cout<<mid<<endl;
}
else
cout<<max<<endl;
}

return 0;
}

POJ - 3104 :Drying