1. 程式人生 > >POJ - 2376 Cleaning Shifts 貪心(最小區間覆蓋)

POJ - 2376 Cleaning Shifts 貪心(最小區間覆蓋)

red his 時間 sin lines farmer cte number limit

Cleaning Shifts Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows. 題意:農夫John和他的cows系列。這次cows們被John命令cleaning shifts,給你總區間時間,和每頭cow負責clean的子區間時段,問怎樣安排可以使最少的cow打掃於整個時間區間。 思路:典型貪心。先對所有cow開始clean的時間升序排序,然後再依次遍歷每頭cow,保證開始時間在上一頭cow時段內,使結束時間最長。(註意:不重疊但相鄰也成立)一旦超出上一頭cow的結束時段,更新cow,並繼續向下遍歷。
#include<stdio.h>
#include<algorithm>
using namespace std;

struct Node{
    int l,r;
}node[25005];
bool cmp(Node a,Node b)
{
    if(a.l==b.l) return a.r>b.r;
    return a.l<b.l;
}
int main()
{
    int n,t,c,f,min,max,i;
    scanf("%d%d",&n,&t);
    for(i=1;i<=n;i++){
        scanf("%d%d",&node[i].l,&node[i].r);
    }
    sort(node+1,node+n+1,cmp);
    c=1;f=0;
    min=node[1].r;
    max=node[1].r; 
    for(i=2;i<=n;i++){
        if(node[i].l<=min+1){    //坑點。。相鄰即相連
            if(node[i].r>max){
                f=1;
                max=node[i].r;
                if(max>=t) break;
            }
        }
        else{
            min=max;
            c++;
            f=0;
            if(node[i].l<=min+1){   //同上
                if(node[i].r>max){
                    f=1;
                    max=node[i].r;
                    if(max>=t) break;
                }
            }
            else break;
        }
    }
    if(node[1].l<=1&&max>=t) printf("%d\n",c+f);
    else printf("-1\n");
    return 0;
}

POJ - 2376 Cleaning Shifts 貪心(最小區間覆蓋)