1. 程式人生 > >POJ 3069 Saruman's Army

POJ 3069 Saruman's Army

mon num sample printf ack over col acc tracking

Saruman‘s Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6688 Accepted: 3424

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R

units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x

1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = ?1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.


題意:

直線上有n個點,從這n個點中選擇若幹個,給他們加上標記。

對每個點,其距離為r以內的區域裏必須有帶標記的點(自己本身帶有標記的點,能夠覺得與其距離為0的地方有一個帶有標記的點)。在滿足這個條件的情況下,希望能為盡可能少的點加入標記,請問至少要有多少點被加上標記


#include <cstdio>
#include <algorithm>
using namespace std;

int r, n;
int x[1001];

void solve()
{
    sort(x, x + n);
    int i = 0, ans = 0;
    while (i < n){
        int s = x[i++];   //s是沒有被覆蓋的最左的點的位置
        while (i < n && x[i] <= s + r)  //一直向右前進直到距s的距離大於r的點
            i++;
        int p = x[i - 1];  //p是新加上標點的點的位置
        while (i < n && x[i] <= p + r)   //一直向右前進直到距p的距離大於r的點
            i++;
        ans++;
    }
    printf("%d\n", ans);
}

int main()
{
    while (scanf("%d%d", &r, &n) != EOF){
        if (r == -1 && n == -1)
            break;
        for (int i = 0; i < n; i++){
            scanf("%d", &x[i]);
        }
        solve();
    }
    return 0;
}


POJ 3069 Saruman&#39;s Army