1. 程式人生 > >scu-4440 rectangle (非原創)

scu-4440 rectangle (非原創)

else if -1 not eat note divide test paper all

Rectangle

frog has a piece of paper divided into nn rows and mm columns. Today, she would like to draw a rectangle whose perimeter is not greater than kk .

技術分享

There are 88 (out of 99 ) ways when n=m=2,k=6n=m=2,k=6

Find the number of ways of drawing.

Input

The input consists of multiple tests. For each test:

The first line contains 33 integer n,m,kn,m,k (1n,m5?104,0k1091≤n,m≤5?104,0≤k≤109 ).

Output

For each test, write 11 integer which denotes the number of ways of drawing.

Sample Input

    2 2 6
    1 1 0
    50000 50000 1000000000

Sample Output

    8
    0
    1562562500625000000

這題我看到一個題解,感覺寫的很透徹,放這存一下。

題意:給定長度,求在不大於這個長度下,有多少個矩形(矩形周長不大於給定長度)。
主要是用到了矩形的對稱性
以及以下這個性質
在長為n,寬為m的矩形上,長為i,寬為j的矩陣個數為(n-i+1)x(m-j+1)。

證明:
首先考慮n
在一個長為n的矩形中
1~i,2~i+1,3~i+2,n-i+1~n;
分別為長為i的矩形
同理考慮m
寬為j的矩形
1~j,2~j+1,3~j+2,m-j+1~m;
這樣的話
1~j下就有n-i+1個矩形
所以總共就是
(n-i+1)x(m-j+1);

那麽這道題的答案就出來了
記num=k/2-i (num>0)
k為周長
i為長
num為寬
在num<=m時
num可以取1,2,3,…,num
所以答案為
ans=(n-i+1)x(m-1+1)+(n-i+1)x(m-2+1)+…+(n-i+1)*(m-num+1);
提取(n-i+1),就是一個等差數列
所以
ans+=(n-i+1)x(2m-num+1)num/2;
當num>m時
num替換為m
ans+=(n-i+1)x(2m-m+1)m/2;
ans+=(n-i+1)x(m+1)m/2;
代碼如下
#include<cstdio>
#define ll long long
ll n,m,k,ans,num;
int main()
{
  while(~scanf("%lld%lld%lld",&n,&m,&k))
  {
    ans=0;
    for(int i=1;i<=n;i++)
    {
      num=k/2-i;
      if(num<=m&&num>0)ans+=(n-i+1)*(2*m-num+1)*num/2;
      else if(num>0)ans+=(n-i+1)*(1+m)*m/2;
    }
    printf("%lld\n",ans);
  }
  return 0;
}

  


題解地址:http://blog.csdn.net/VictorZC8/article/details/51242491

scu-4440 rectangle (非原創)