1. 程式人生 > >HDU - 1686 Oulipo

HDU - 1686 Oulipo

without con org har find scan with csharp per

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

InputThe first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.
OutputFor every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
最基礎的KMP匹配
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

char s[10005],ss[1000005];
int T,n,m,Next[10005];

void getnext(char* s,int m)
{
	Next[0]=0;
	Next[1]=0;
	for(int i=1;i<m;i++)
	{
		int j=Next[i];
		while(j&&s[i]!=s[j])
			j=Next[j];
		if(s[i]==s[j])
			Next[i+1]=j+1;
			else
				Next[i+1]=0;
	}
}

int main()
{
	scanf("%d",&T);
	while(T--)
	{
		int sum=0;
		memset(Next,0,sizeof(Next));
		memset(ss,0,sizeof(ss));
		memset(s,0,sizeof(s));
		scanf("%s",s);
		scanf("%s",ss);
		n=strlen(ss);
		m=strlen(s);
		getnext(s,m);
		int j=0;
		for(int i=0;i<n;i++)
		{
			while(j&&s[j]!=ss[i])
				j=Next[j];
			if(ss[i]==s[j])
				j++;
			if(j==m)
				sum++;
		}
		printf("%d\n",sum);
	}
	
	
	return 0;
}

  

HDU - 1686 Oulipo