1. 程式人生 > >POJ 1426 Find The Multiple(DFS,BFS)

POJ 1426 Find The Multiple(DFS,BFS)

ons pro sum 數字 there lin queue hat 一個數

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
題意:
  
對於一個數字n,找到n的倍數且這個數的每一位只能是0和1。
題解:
  
因為是special judge,所以只要輸出任何一個滿足條件的就可以了。因為n<=200,所以最小滿足條件的答案在18位以內(long long就足夠了)。
兩種解法:DFS和BFS都行。
DFS:
#include<iostream>
using namespace std;
int n;
bool flag;
void dfs(long long x,int k)
{
    if(flag)
        return;
    if(x%n==0)
    {
        flag
=true; cout<<x<<endl; return ; } if(k==18)//搜索到18位的時候還沒找到就返回 return ; dfs(x*10,k+1); dfs(x*10+1,k+1); } int main() { while(cin>>n&&n) { flag=false; dfs(1,0); } return 0; }

BFS:

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
typedef long long LL;
LL bfs(int n)
{
    queue<LL> que;
    que.push(1);//從1開始搜索
    while(que.size())
    {
        LL cur=que.front();
        que.pop();
        if(cur%n==0)
            return cur;
        que.push(cur*10);
        que.push(cur*10+1);
    }
    return -1;
}
int main()
{
    int n;
    while(cin>>n,n)
    {
        cout<<bfs(n)<<endl;
    }
    return 0;
}

POJ 1426 Find The Multiple(DFS,BFS)