1. 程式人生 > >POJ 題目1157 LITTLE SHOP OF FLOWERS(DP)

POJ 題目1157 LITTLE SHOP OF FLOWERS(DP)

pop include ffffff suppose produce str tween cin 0ms

LITTLE SHOP OF FLOWERS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19457 Accepted: 8966

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7 23 -5 -24 16

2 (begonias)

5 21 -4 10 23

3 (carnations)

-21

5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

  • The first line contains two numbers: F, V.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

Source

IOI 1999 題目大意:有n個鮮花,m個花瓶,編號i的花插到編號j的花瓶中後,比i大的編號的花,僅僅能插進比j大的編號的花瓶裏,每一個不同編號插入不同編號的花瓶都有一個價值,求插這n束花的掙得價值 ac代碼
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
#define max(a,b) (a>b?a:b)
int map[1010][1010],dp[1010][1010];
void init(int n,int m)
{
	int i,j;
	for(i=1;i<=n;i++)
		for(j=1;j<=m;j++)
			dp[i][j]=-INF;
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j,k;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				scanf("%d",&map[i][j]);
			}
		}
		init(n,m);
		for(j=1;j<=m;j++)
			dp[1][j]=map[1][j];
		for(i=2;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				for(k=1;k<j;k++)
					dp[i][j]=max(dp[i][j],dp[i-1][k]+map[i][j]);
			}
		}
		int ans=-INF;
		for(i=1;i<=m;i++)
		{
			ans=max(ans,dp[n][i]);
		}
		printf("%d\n",ans);
	}
}

POJ 題目1157 LITTLE SHOP OF FLOWERS(DP)