1. 程式人生 > >POJ 2831 Can We Build This One?

POJ 2831 Can We Build This One?

people ext per center ble contain ant pop under

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1728 Accepted: 643
Case Time Limit: 2000MS

Description

“Highways are built, then life is rich.” Now people of Big Town want to become rich, so they are planning to build highways to connect their villages.

Big Town is really big and has many villages. Its people plan to build some highways between some pairs of villages so that every pair of villages is connected by the highways either directly or indirectly. After surveying the geographical surroundings, they find that there are some paths along with highways can be built. Every path is denoted by a triplet (a

, b, c) which means a highway can built between the a-th village and the b-th village with a cost of c. In order to save money, they will select only part of the paths to build highways along so that the total cost to build highways along the selected paths is minimal under the condition that every pair of villages is connected.

It is possible that multiple such selections exist. People from every village want to have those highways of good interest to them built. But some highways can never appear in the selection since they are much too costly. So people ask whether a certain highway can be selected if they agree to cut the cost. Your task is to design a program to answer their queries.

Input

The first line of input contains three integers N, M and Q (1 < N ≤ 1,000, N − 1 ≤ M ≤ 100,000, 0 < Q ≤ 100,000), where N is the number of villages, M is the number of paths, and Q is the number of queries. Each of the next M lines contains three integers a, b, and c (1 ≤ a, bN, ab, 0 ≤ c ≤ 1,000,000). The triplet (a, b, c) describes a path. Each of following Q lines contains two integer i and x (1 ≤ iM, 0 ≤ x) describing a query, “Can a highway be built along the i-th path if the cost of is reduced to x?” x is strictly lower than the original cost of building a highway along the i-th path. It is assumed that every pair of village will be connected either directly or indirectly if all possible highways are built. And there may be more than one highway that can be built between a pair of villages.

Output

Output one line for each query. Output either “Yes” or “No” as the answer to the the query.

Sample Input

3 4 3
1 2 10
1 3 6
2 3 4
1 3 7
4 6
1 7
1 5

Sample Output

Yes
No
Yes

Source

POJ Monthly--2006.05.28, zhucheng 次小生成樹+不知道是不是的spfa 如果降低後費用小於等於兩點間的最大費用,則輸出Yes. 否則輸出No. prim算法好寫些,但我忘記怎麽寫了。。 屠龍寶刀點擊就送
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#define M 100005 
#define N 1005

using namespace std;
struct Edge
{
    int x,y,z;
    bool operator <(Edge a)const
    {
        return z<a.z;
    }
}edge[M],oedge[M];
bool vis[N];
int fa[N],n,m,q,dist[N][N];
int find_(int x) {return x==fa[x]?x:fa[x]=find_(fa[x]);}
struct node
{
    int to,dis;
    node (int to=0,int dis=0) : to(to),dis(dis) {}
};
vector<node>vec[N]; 
void update(int s)
{
    memset(vis,0,sizeof(vis));
    dist[s][s]=0;
    vis[s]=1;
    queue<int>Q;
    Q.push(s);
    for(int now=Q.front();!Q.empty();Q.pop(),now=Q.front())
    {
        for(int i=0;i<vec[now].size();i++)
        {
            int v=vec[now][i].to,w=vec[now][i].dis;
            if(vis[v]) continue;
            dist[s][v]=max(dist[s][now],w);
            vis[v]=1;
            Q.push(v);
        }
    }
}
int main()
{
    scanf("%d%d%d",&n,&m,&q);
    for(int a,b,c,i=1;i<=m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        edge[i].x=a;
        edge[i].y=b;
        edge[i].z=c;
        oedge[i]=edge[i];
    }
    for(int i=1;i<=n;i++) fa[i]=i;
    sort(edge+1,edge+1+m);
    int num=0;
    for(int i=1;i<=m;i++)
    {
        int fx=find_(edge[i].x),fy=find_(edge[i].y); 
        if(fx!=fy)
        {
            fa[fy]=fx;
            num++;
            vec[edge[i].x].push_back(node(edge[i].y,edge[i].z));
            vec[edge[i].y].push_back(node(edge[i].x,edge[i].z));
            if(num==n-1) break;
        }
    }
    for(int i=1;i<=n;i++) update(i);
    for(int xx,yy;q--;)
    {
        scanf("%d%d",&xx,&yy);
        if(dist[oedge[xx].x][oedge[xx].y]>=yy) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

POJ 2831 Can We Build This One?