1. 程式人生 > >HDU 1068 Girls and Boys

HDU 1068 Girls and Boys

read roman tex field ant ini http ati result

Girls and Boys

Problem Description the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input 7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

Sample Output 5 2

Source Southeastern Europe 2000
#include <cstdio>
#include <cstring>
using namespace std;
int n,m,s,t,ans,w[2333][2333],a[1000000];
bool vis[100000];
inline void read(int &now)
{
    char ch; ch=getchar(); now=0;
    while(ch>9||ch<0) ch=getchar();
    while(ch>=0&&ch<=9) now=now*10+ch-0,ch=getchar();
}
int find(int x)
{
    for(int i=0;i<n;i++)
    {
        if(w[x][i]&&!vis[i])
        {
            vis[i]=true;
            if(!a[i]||find(a[i]))
            {
                a[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int p,u,v,i=0;i<n;i++)
        {
            read(v); read(p);
            for(int j=1;j<=p;j++)
            {
                read(u);
                w[v][u]=1;
            }
        }
        for(int i=0;i<n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(find(i)) ans++;
        }
        printf("%d\n",n-ans/2);
        memset(w,0,sizeof(w));
        memset(a,0,sizeof(a));
        ans=0;
    }
    return 0;
}

HDU 1068 Girls and Boys