1. 程式人生 > >POJ A Plug for UNIX (最大流 建圖)

POJ A Plug for UNIX (最大流 建圖)

建圖 inter tel != 不能 which mic ios ber

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling

irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn‘t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.

In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

現在有n個插頭,m個用電器,每個用電器有一個自己的插口,還有k個插頭轉化器(將插頭從一種轉換為另一種),問你最少有多少個充電器充不上電
主要思路就是建圖,我們把源點與每個用電器建一條容量為1的邊,每個用電器跟自己的插頭建一條容量為1的邊,在對於每個轉換器的頭跟尾建一條容量為inf的邊,跑最大流即可
為什麽要對轉換器建一條inf的邊呢?因為不能讓這條邊容量的大小卡住了源點的流,所以容量盡可能大
細節!!!!!輸完n個插頭之後還可能出現新的插頭,別忘了繼續加入map
maxn開大一點
#include <string>
#include <cstdio>
#include <cstring>
#include <map>
#include <cmath>
#include <queue>
#include <iostream>
using namespace std;
#define inf 0x3f3f3f3f
const int maxn = 810;
int c[maxn][maxn];
int dep[maxn];
int cur[maxn];
int n,m,k;
map<string,int> name;
int tot;
int bfs (int s,int t)
{
    memset(dep,-1,sizeof dep);
    queue<int> q;
    while (!q.empty()) q.pop();
    dep[s] = 0;
    q.push(s);
    while (!q.empty()){
        int u=q.front();
        q.pop();
        for (int v=0;v<=801;++v){
            if (c[u][v]>0&&dep[v]==-1){
                dep[v]=dep[u]+1;
                q.push(v);
            }
        }
    }
    return dep[t]!=-1;
}
int dfs (int u,int mi,int t)
{
    if (u==t)
        return mi;
    int tmp;
    for (int &v=cur[u];v<=801;++v){
        if (c[u][v]>0&&dep[v]==dep[u]+1&&(tmp=dfs(v,min(mi,c[u][v]),t))){
            c[u][v]-=tmp;
            c[v][u]+=tmp;
            return tmp;
        }
    }
    return 0;
}
int dinic ()
{
    int ans = 0;
    int tmp;
    while (bfs(0,801)){
        while (1){
            for (int i=0;i<maxn;++i) cur[i]=0;
            tmp = dfs(0,inf,801);
            if (tmp==0)
                break;
            ans+=tmp;
        }
    }
    return ans;
}
int main()
{
    //freopen("de.txt","r",stdin);
    while(~scanf("%d",&n)){
        memset(c,0,sizeof c);
        tot=1;
        for (int i=1;i<=n;++i){
            string str;
            cin>>str;
            name[str]=i;
            c[name[str]][801]=1;
            tot++;
        }
        scanf("%d",&m);
        for (int i=1;i<=m;++i){
            string stra,strb;
            cin>>stra>>strb;
            name[stra]=tot++;
            if (!name[strb]) name[strb]=tot++;
            c[0][name[stra]]=1;
            c[name[stra]][name[strb]]=1;
        }
        scanf("%d",&k);
        for (int i=0;i<k;++i){
            string a,b;
            cin>>a>>b;
            if (!name[a]) name[a]=tot++;
            if (!name[b]) name[b]=tot++;
            c[name[a]][name[b]]=inf;
        }
        printf("%d\n",m-dinic());
    }
    return 0;
}

 

POJ A Plug for UNIX (最大流 建圖)