1. 程式人生 > >hdu 1019 Least Common Multiple

hdu 1019 Least Common Multiple

lin instance 最大公約數 turn ati mit ... amp ext

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54584 Accepted Submission(s): 20824


Problem Description The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input 2 3 5 7 15 6 4 10296 936 1287 792 1

Sample Output 105 10296 只要掌握基本的求最大公約數 與 最小公倍數的方法 即可簡單解決該問題~

//求最小公倍數算法:

//最小公倍數=兩整數的乘積 ÷最大公約數

//求最大公約數算法:

其中之一 --> 輾轉相除法:

//有兩整數a和b;

//① a%b得余數c

//② 若c=0,則b即為兩數的最大公約數

//③ 若c≠0,則a=b,b=c,再回去執行①

代碼如下:

#include <iostream>
#define N 10010
using namespace std;

long long gcd(long long a, long long b)
{
  if(a % b == 0)
  {
    return b;
  }
  else
  {
    return gcd(b,a % b);
  }
}

long long num[N];
int main()

{
  int n, a;
  long long c;
  scanf("%d", &n);
  while(n--)
  {
    c= 1;
    scanf("%d", &a);
    for(int i = 0;i < a; ++i)
    {
      scanf("%I64d", &num[i]);
    }
    for(int i = 0;i < a; ++i)
    {
      if(c % num[i] == 0)
      {
        continue;
      }
      else
      {
        c = c*num[i]/gcd(c,num[i]);
      }
    }
    printf("%ld\n", c);
  }
  return 0;
}

hdu 1019 Least Common Multiple