1. 程式人生 > >HDU 3336 Count the string

HDU 3336 Count the string

inpu sum problems eof monthly pro chmod ext cas

Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11476 Accepted Submission(s): 5340

Problem Description It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007. Input The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
Output For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007. Sample Input 1 4 abab Sample Output 6 Author [email protected] Source HDOJ Monthly Contest – 2010.03.06 Recommend lcy | We have carefully selected several similar problems for you: 1711 1686 3746 1358 3341 思路:dp+KMP
#include<cstdio> 
#include<cstring>
using namespace std;
int n,m;  
char s[200010];  
int next[200010],dp[200010];  
void getnext(){
    int k=-1,j=0;
    next[0]=-1;
    while(j<m){
        if(k==-1||s[j]==s[k]){
            j++;k++;
            next[j]=k;
        }
        else k=next[k];
    }
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        memset(dp,0,sizeof(dp));
        memset(next,0,sizeof(next));
        scanf("%d",&m);
        scanf("%s",s);
        getnext();
        dp[0]=0;
        int sum=0;
        for(int i=1;i<=m;i++){
            dp[i]=dp[next[i]]+1;
            sum=(sum+dp[i])%10007;
        }
        printf("%d\n",sum); 
    }
}

HDU 3336 Count the string