1. 程式人生 > >HUD 1506 Largest Rectangle in a Histogram

HUD 1506 Largest Rectangle in a Histogram

problem ssi member img 個數 accept fin character ref

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19580 Accepted Submission(s): 5921


Problem Description A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
技術分享
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input 7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0

Sample Output 8 4000

Source University of Ulm Local Contest 2003

Recommend LL | We have carefully selected several similar problems for you: 1505 1069 1087 1058 1176 經典問題 廣告印刷 有n個數ai。從中選出一段區間[L,R],使得(R-L+1)*min{a_L,…,a_R}最大 兩個單調隊列求每個點向兩側擴展到的最遠距離
#include<cstdio>
#include<algorithm>
using namespace std;
#define LL long long 
const int maxn= 100005;
#ifdef WIN32
#define lld "I64d"
#else
#define lld "lld"
#endif

int a[maxn],b[maxn];
int l[maxn],r[maxn],tmp[maxn],q[maxn];
int n,m;
void work(int c[] ,int d[]) {
    q[1]=c[1]; tmp[1]=1;
    int head=1,tail=1;
    for(int i=2;i<=n;++i) {
        while(head<=tail&&q[tail]>c[i]) d[tmp[tail--]]=i-1;
        q[++tail]=c[i];
        tmp[tail]=i;
       }
       while(head<=tail) d[tmp[head++]]=n;
}
int main() {
    while(scanf("%d",&n)&&n!=0) {
        LL ans=0;
        for(int i=1;i<=n;++i) 
            scanf("%d",a+i),b[n-i+1]=a[i];
        work(a,r);     
        work(b,l);
        for(int i=1;i<=n;++i) tmp[i]=l[i];
        for(int i=1;i<=n;++i) l[n-i+1]=n-tmp[i]+1;
        for(int i=1;i<=n;++i) ans=max(ans,1ll*a[i]*(r[i]-l[i]+1));
        printf("%lld\n",ans);
    }
    return 0;
}

HUD 1506 Largest Rectangle in a Histogram