1. 程式人生 > >hdu2010(dfs+剪枝)

hdu2010(dfs+剪枝)

nsis lines eno door open note isa 發現 fas

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 131619 Accepted Submission(s): 35432


Problem Description The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggie cannot enter;
‘S‘: the start point of the doggie;
‘D‘: the Door; or
‘.‘: an empty block.

The input is terminated with three 0‘s. This test case is not to be processed.

Output For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input 4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

Sample Output NO YES 題意是恰好走k步從S點到達D點,所以我們需要剪枝。 1:s點的坐標減去d點的坐標要恰好等於k..即:abs(ax-bx)+abs(ay-by)==k; 2:判斷奇偶:假設 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 我們發現從0走一步一定走到1,從1走一步一定走到0。 也就是說,如果當前的狗所在的坐標與D的坐標奇偶性不一樣,那麽狗需要走奇數步。 同理,如果狗所在坐標與D的坐標奇偶性一樣,那麽狗需要走偶數步數。 也就是說,狗的坐標x、y和對2取余是它的奇偶性,Dxy和對2取余是D的奇偶性。 兩個奇偶性一加再對2取余,拿這個余數去與剩下時間對2取余的余數作比較即可 技術分享
#include<iostream>
#include<string.h>
using namespace std;
#include<math.h>
char s[10][10];
int ax,ay,bx,by,n,m,k;
int t[4][2]={1,0,-1,0,0,1,0,-1},visit[10][10],flag;
void dfs(int x,int y,int count)
{
    int mx,my,i;
    if(x==bx&&y==by)
{
    if(k==count){
    
    flag=1;
}    
    return;
}
   if(count>=k)
     return;
      if(s[x][y]!=X)
      {
          for(i=0;i<4;i++)
          {
              mx=x+t[i][0];
              my=y+t[i][1];
              if(s[mx][my]!=X&&mx>=1&&mx<=n&&my>=1&&my<=m&&!visit[mx][my])
              {
                  visit[mx][my]=1;
                  dfs(mx,my,count+1);
                  visit[mx][my]=0;
                  if(flag)   //註意,在找到了目標之後,就不需要再找!以往編寫dfs時,沒有註意這點,就會超時 
                  return;
              }
          }
      }
}
int main()
{
    while(cin>>n>>m>>k)
    {
        if(n==0&&m==0&&k==0)
        return 0;
        int i,count=0;
        flag=0;
        for(i=1;i<=n;i++)
        {
            getchar();
            for(int j=1;j<=m;j++)
            {
                cin>>s[i][j];
                if(s[i][j]==S)
                {
                    ax=i;ay=j;
                }
                if(s[i][j]==D)
                {
                    bx=i;by=j;
                }
                
            }
        }
        getchar();
        memset(visit,0,sizeof(visit));
        if((abs(ax-bx)+abs(ay-by))>k||(ax+ay+bx+by+k)%2==1)//剪枝幹 
        {
            //cout<<"*"<<endl;
            cout<<"NO"<<endl;
            continue;
        }
        visit[ax][ay]=1;
        count=0;
        dfs(ax,ay,count);
        if(flag==1)
        cout<<"YES"<<endl;
        else
        cout<<"NO"<<endl;  
    }
    return 0;
}
View Code

hdu2010(dfs+剪枝)