1. 程式人生 > >POJ 2955 - Brackets - [區間DP]

POJ 2955 - Brackets - [區間DP]

更新 char == else ase cas other sse multi

題目鏈接:http://poj.org/problem?id=2955

Time Limit: 1000MS Memory Limit: 65536K

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

題意:

給出一個包含“(”、“)”、“[”、“]”的括號串,求有多少個相匹配的括號;

題解:

區間dp,設dp[i][j]為str[i~j]範圍內的答案,即dp[0][len-1]即問題所求答案;

假設我們在求dp[i][j]時,已經知道所有dp[ii][jj](i<ii<jj<j),那麽,做一下兩項操作即可:

①先OB一下str[i]和str[j]是不是匹配的,如果是的話,嘗試更新dp[i][j]:dp[i][j] = max( dp[i][j] , dp[i+1][j-1]+2 )

②為了保證dp[i][j]的正確性,枚舉k=i~j,嘗試更新dp[i][j]:dp[i][j] = max( dp[i][j] , dp[i][k]+dp[k][j] )

完美~

AC代碼:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[105];
int dp[105][105];
bool check(char a,char b)
{
    if( (a==(&&b==)) || (a==[&&b==]) ) return 1;
    else return 0;
}
int main()
{
    while(scanf("%s",str))
    {
        if(str[0]==e) break;

        int len=strlen(str);
        memset(dp,0,sizeof(dp));
        for(int l=2;l<=len;l++)
        {
            for(int i=0,j=i+l-1;j<len;i++,j=i+l-1)
            {
                if(check(str[i],str[j])) dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);

                for(int k=i;k<=j;k++) dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]);
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
}

POJ 2955 - Brackets - [區間DP]