1. 程式人生 > >POJ2096Collecting Bugs(數學期望,概率DP)

POJ2096Collecting Bugs(數學期望,概率DP)

like ini namespace reads cts require main pread 概率dp

問題:

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It‘s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan‘s opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan‘s work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan‘s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

題意:

有s個系統,有n種bug,bug的數量不限,一位程序員每天可以發現一個bug 現在求發現n種bug存在s個系統中並且每個系統都要被發現bug的平均天數(期望)

即,一個n*s的矩陣,每天任選一個格子上塗一筆(可以重復塗),求達到每一行每一列都至少被塗了一筆的天數期望。

假設一個矩陣每一行每一列至少一個點被塗,我們稱這個矩陣被覆蓋。

思路:

從後向前推。

dp[i][j]表示在以及覆蓋了一個i*j的矩陣的情況下要達到覆蓋n*m的矩陣的天數期望。

dp[i][j]=dp[i][j+1]*p1+dp[i+1][j]*p2+dp[i+1][j+1]*p3+dp[i][j]*p4+1;

概率dp,公式自己推。

疑問:

為什麽輸出時".lf"WA 了,然而".f"AC了,這個影響精度嗎。

#include<cstdio>
#include<cstdlib>
#include<iostream>
using namespace std;
double dp[1010][1010];
int main()
{
    int n,s,i,j;
    while(~scanf("%d%d",&n,&s)){
        dp[n][s]=dp[n+1][s]=dp[n][s+1]=dp[n+1][s+1] =0;
        for(i=n;i>=0;i--)
         for(j=s;j>=0;j--){
             if(i==n&&j==s) continue;
             dp[i][j]=(i*(s-j)*dp[i][j+1]+(n-i)*j*dp[i+1][j]+(n-i)*(s-j)*dp[i+1][j+1]+n*s)/(n*s-i*j);
         }
        printf("%.4f\n",dp[0][0]);
    }
    return 0;
}

POJ2096Collecting Bugs(數學期望,概率DP)