1. 程式人生 > >POJ2689:Prime Distance(大數區間素數篩)

POJ2689:Prime Distance(大數區間素數篩)

possible lib ios rop sel poj art eve led

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

題意:求一個長度不超過1e6的區間[L,R](L和R很大)中,距離最近和最遠的素數對。

思路:求出1到sqrt(R)間的素數,然後利用這些素數篩去[L,R]中的合數。

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=100000;
int p[maxn+10],vis[maxn+10],cnt,L,R;
int wl,wr,vl,vr,tag[maxn*10+10],times;
void prime()
{
    for(int i=2;i<=maxn;i++){
        if(!vis[i]) p[++cnt]=i;
        for(int j=1;j<=cnt&&p[j]*i<=maxn;j++){
            vis[i*p[j]]=1;
            if(i%p[j]==0) break;
        }
    }
}
void find()
{
    for(int i=1;i<=cnt&&p[i]<=R;i++){
        int Now=(max(L,maxn)/p[i])*p[i];
        while(Now<L) Now+=p[i];
        while(Now<=R){
            tag[Now-L+1]=times;
            Now+=p[i];
        }
    }
    int pre=0;
    for(int i=L;i<=R;i++){
        if((i<=maxn&&!vis[i])||(i>maxn&&tag[i-L+1]!=times)) {
            if(pre) {
                if(wl==0) wl=vl=pre,wr=vr=i;
                else {
                    if(i-pre>wr-wl) wl=pre,wr=i;
                    if(i-pre<vr-vl) vl=pre,vr=i;
                }
            }
            pre=i;
        }
    }
    if(wl==0) printf("There are no adjacent primes.\n");
    else printf("%d,%d are closest, %d,%d are most distant.\n",vl,vr,wl,wr);
    return ;
}
int main()
{
    prime();
    while(~scanf("%d%d",&L,&R)){
        times++;
        wl=wr=vl=vr=0;//da xiao
        find();
    }
    return 0;
}

POJ2689:Prime Distance(大數區間素數篩)