1. 程式人生 > >ACM練習中關於LCS的題目

ACM練習中關於LCS的題目

city ply sage wan als size expect planning res

You are planning to take some rest and to go out on vacation, but you really don’t know which cities you should visit. So, you ask your parents for help. Your mother says “My son, you MUST visit Paris, Madrid, Lisboa and London. But it’s only fun in this order.” Then your father says: “Son, if you’re planning to travel, go first to Paris, then to Lisboa, then to London and then, at last, go to Madrid. I know what I’m talking about.”

  Now you’re a bit confused, as you didn’t expected this situation. You’re afraid that you’ll hurt your mother if you follow your father’s suggestion. But you’re also afraid to hurt your father if you follow you mother’s suggestion. But it can get worse, because you can hurt both of them if you simply ignore their suggestions!

  Thus, you decide that you’ll try to follow their suggestions in the better way that you can. So, you realize that the “Paris-Lisboa-London” order is the one which better satisfies both your mother and your father. Afterwards you can say that you could not visit Madrid, even though you would’ve liked it very much.

  If your father have suggested the “London-Paris-Lisboa-Madrid” order, then you would have two orders, “Paris-Lisboa” and “Paris-Madrid”, that would better satisfy both of your parent’s suggestions. In this case, you could only visit 2 cities.

  You want to avoid problems like this one in the future. And what if their travel suggestions were bigger? Probably you would not find the better way very easy. So, you decided to write a program to help you in this task. You’ll represent each city by one character, using uppercase letters, lowercase letters, digits and the space. Thus, you can have at most 63 different cities to visit. But it’s possible that you’ll visit some city more than once.

  If you represent Paris with ‘a’, Madrid with ‘b’, Lisboa with ‘c’ and London with ‘d’, then your mother’s suggestion would be ‘abcd’ and you father’s suggestion would be ‘acdb’ (or ‘dacb’, in the second example).

  The program will read two travel sequences and it must answer how many cities you can travel to such that you’ll satisfy both of your parents and it’s maximum.

Input

The input will consist on an arbitrary number of city sequence pairs. The end of input occurs when the first sequence starts with an ‘#’ character (without the quotes). Your program should not process this case. Each travel sequence will be on a line alone and will be formed by legal characters (as defined above). All travel sequences will appear in a single line and will have at most 100 cities.

Output

For each sequence pair, you must print the following message in a line alone:

Case #d: you can visit at most K cities.

  Where d stands for the test case number (starting from 1) and K is the maximum number of cities you can visit such that you’ll satisfy both you father’s suggestion and you mother’s suggestion.

Sample Input

abcd

acdb

abcd

dacb

#

Sample Output

Case #1: you can visit at most 3 cities.

Case #2: you can visit at most 2 cities.

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

簡單的最長子序列匹配,算法沒什麽難度,但是想要ac還需要註意的是程序的輸入和輸出,不要因為題目簡單而在最簡單的輸入輸出上栽跟頭,本題中輸入字符串c++必須使用getline(cin,str),否則ac就會失敗

ac代碼如下:

#include <iostream>
#include <cstring>

using namespace std;  
int d[110][110];  
int main()  
{  
    string a,b;  
    int i,j;
    int count=0;  
    while(getline(cin,a))  //必須使用getline 才能ac,cin輸入字符串將會錯誤
    {
        if(a=="#")
        {
            break;
        }
        getline(cin,b);
        memset(d,0,sizeof(d));  
        for(i=1; i<=a.size(); i++)  
            for(j=1; j<=b.size(); j++)  
            {  
                if(a[i-1] == b[j-1])  
                {  
                    d[i][j] = d[i-1][j-1]+1;  
                }     
                else  
                {  
                    d[i][j] = max(d[i-1][j],d[i][j-1]);  
                }  
            }  
        cout << "Case #"<<++count<<": you can visit at most "<<d[a.size()][b.size()]<<" cities." << endl;  
        a.clear();  
        b.clear();
    }  
    return 0;  
}  

ACM練習中關於LCS的題目