1. 程式人生 > >POJ 1651 Multiplication Puzzle (區間DP)

POJ 1651 Multiplication Puzzle (區間DP)

contain 個數 ++ %d str poi point return IE

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650


題解:?設dp[i][[j]?為從i到j取完出了a[i]和a[j]這兩個數的最小代價。

終於所要求出的是dp[1][n]。

如果在i到j區間內最後一個取a[k],那麽子問題便能夠看得出來:求出dp[i][k]和dp[k][j]的最小代價。求出這兩個子問題的代價再加上最後一個取出a[k]的代價,即為dp[i][j]的代價。

問題轉化為求出子問題的代價,直到僅僅剩下三個數為止,三個數僅僅能取中間的數。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#define lson o << 1, l, m
#define rson o << 1|1, m+1, r
using namespace std;
typedef long long LL;
const int MAX=0x3f3f3f3f;
const int maxn = 100+10;
int n, dp[maxn][maxn], a[maxn];
int main()
{
    scanf("%d", &n);
    for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
    for(int i = 2; i <= n-1; i++) dp[i-1][i+1] = a[i-1]*a[i]*a[i+1];  //邊界,三個數僅僅能取中間的數
    for(int len = 4; len <= n; len ++)
        for(int i = 1; i <= n-len+1; i++) {
            int j = i+len-1;
            dp[i][j] = MAX;
            for(int k = i+1; k <= j-1; k++)
                dp[i][j] = min(dp[i][j], dp[i][k]+dp[k][j] + a[j]*a[k]*a[i]);
        }
    printf("%d\n", dp[1][n]);
    return 0;
}


??

POJ 1651 Multiplication Puzzle (區間DP)